summaryrefslogtreecommitdiff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2020-08-29 20:11:53 -0400
committerLeo Famulari <leo@famulari.name>2020-08-30 13:53:55 -0400
commitb39541859dcef62fef174392092a456b03a15498 (patch)
tree3c63fb92e043c1359f0281f60fdac5075fd120ad /gnu/packages/linux.scm
parent71a85fedcdf0232e5eae69af6cc139a8aafaea10 (diff)
gnu: Remove linux-libre 5.7.
The 5.7 kernel series is no longer supported upstream. * gnu/packages/linux.scm (deblob-scripts-5.7, linux-libre-5.7-version, linux-libre-5.7-pristine-source, linux-libre-5.7-source, linux-libre-headers-5.7, linux-libre-5.7) Remove variables. * gnu/packages/aux-files/linux-libre/5.7-arm.conf, gnu/packages/aux-files/linux-libre/5.7-arm64.conf, gnu/packages/aux-files/linux-libre/5.7-i686.conf, gnu/packages/aux-files/linux-libre/5.7-x86_64.conf: Delete files. * Makefile.am (AUX_FILES): Remove them.
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm29
1 files changed, 0 insertions, 29 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 26ce379568..d3a6f93b20 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -212,12 +212,6 @@ defconfig. Return the appropriate make target if applicable, otherwise return
(base32 "07z7sglyrfh0706icqqf3shadf638pvyid9386r661ds5lbsa2mw")
(base32 "0j6jba5fcddqlb42f95gjl78jisfla4nswqila074gglcrbnl9q7")))
-(define deblob-scripts-5.7
- (linux-libre-deblob-scripts
- "5.7.18"
- (base32 "1gharhw104wxp9dxjkzzvsqc2xn44mc9yvacc3v7jh7b6bb0a64a")
- (base32 "19mzampqx6j85fbdnl347wsy8zw2fnm189llsjc7jwfm10qc2kms")))
-
(define deblob-scripts-5.4
(linux-libre-deblob-scripts
"5.4.61"
@@ -397,14 +391,6 @@ corresponding UPSTREAM-SOURCE (an origin), using the given DEBLOB-SCRIPTS."
(%upstream-linux-source version hash)
deblob-scripts-5.8)))
-(define-public linux-libre-5.7-version "5.7.19")
-(define-public linux-libre-5.7-pristine-source
- (let ((version linux-libre-5.7-version)
- (hash (base32 "1rwzp51ddlkdzanj6i8jqj5yh0njpzn7ly4r8nnzwkdfp5465721")))
- (make-linux-libre-source version
- (%upstream-linux-source version hash)
- deblob-scripts-5.7)))
-
(define-public linux-libre-5.4-version "5.4.61")
(define-public linux-libre-5.4-pristine-source
(let ((version linux-libre-5.4-version)
@@ -478,11 +464,6 @@ corresponding UPSTREAM-SOURCE (an origin), using the given DEBLOB-SCRIPTS."
(list %boot-logo-patch
%linux-libre-arm-export-__sync_icache_dcache-patch)))
-(define-public linux-libre-5.7-source
- (source-with-patches linux-libre-5.7-pristine-source
- (list %boot-logo-patch
- %linux-libre-arm-export-__sync_icache_dcache-patch)))
-
(define-public linux-libre-5.4-source
(source-with-patches linux-libre-5.4-pristine-source
(list %boot-logo-patch
@@ -586,10 +567,6 @@ corresponding UPSTREAM-SOURCE (an origin), using the given DEBLOB-SCRIPTS."
(make-linux-libre-headers* linux-libre-5.8-version
linux-libre-5.8-source))
-(define-public linux-libre-headers-5.7
- (make-linux-libre-headers* linux-libre-5.7-version
- linux-libre-5.7-source))
-
(define-public linux-libre-headers-5.4
(make-linux-libre-headers* linux-libre-5.4-version
linux-libre-5.4-source))
@@ -868,12 +845,6 @@ It has been modified to remove all non-free binary blobs.")
(define-public linux-libre-source linux-libre-5.8-source)
(define-public linux-libre linux-libre-5.8)
-(define-public linux-libre-5.7
- (make-linux-libre* linux-libre-5.7-version
- linux-libre-5.7-source
- '("x86_64-linux" "i686-linux" "armhf-linux" "aarch64-linux" "riscv64-linux")
- #:configuration-file kernel-config))
-
(define-public linux-libre-5.4
(make-linux-libre* linux-libre-5.4-version
linux-libre-5.4-source