summaryrefslogtreecommitdiff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-08-16 15:53:39 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2018-08-16 17:57:50 +0200
commitbd835ff22ffdfdbdcbca73d07ad706468dba62de (patch)
treeb6e0a46adb380dec0213b733cc971d6f0a298e76 /gnu/packages/linux.scm
parent12b99f753a28d21ba8b6815145f59c74a9041802 (diff)
gnu: multipath-tools: Set CC in #:make-flags.
* gnu/packages/linux.scm (multipath-tools)[arguments]: Set ‘CC=gcc’ in #:make-flags instead of in a custom phase.
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm11
1 files changed, 4 insertions, 7 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 505119d6e1..0477f40943 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -2996,8 +2996,9 @@ arrays when needed.")
#t))))
(build-system gnu-build-system)
(arguments
- '(#:tests? #f ; No tests.
- #:make-flags (list (string-append "DESTDIR="
+ '(#:tests? #f ; no tests
+ #:make-flags (list "CC=gcc"
+ (string-append "DESTDIR="
(assoc-ref %outputs "out"))
"SYSTEMDPATH=lib"
(string-append "LDFLAGS=-Wl,-rpath="
@@ -3020,11 +3021,7 @@ arrays when needed.")
(("/usr/include/libudev.h")
(string-append udev "/include/libudev.h")))
#t)))
- (delete 'configure)
- (add-before 'build 'set-CC
- (lambda _
- (setenv "CC" "gcc")
- #t)))))
+ (delete 'configure))))
(native-inputs
`(("perl" ,perl)
("pkg-config" ,pkg-config)