summaryrefslogtreecommitdiff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2015-08-12 10:36:50 -0400
committerMark H Weaver <mhw@netris.org>2015-08-12 22:10:58 -0400
commitc755c85467456a348ec3a5c52945d9af61039350 (patch)
treefc41ad9c5d3285f3a1ed48af996ae0205e214b27 /gnu/packages/linux.scm
parentc037a0f7ce79d8d67e08694ae20e407b1280d84e (diff)
gnu: Add rfkill.
* gnu/packages/linux.scm (rfkill): New variable.
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 1f258b1218..23562b96fd 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -2084,6 +2084,33 @@ thanks to the use of namespaces.")
is for enabling irq-unmasking and IDE multiple-mode.")
(license (non-copyleft "file://LICENSE.TXT"))))
+(define-public rfkill
+ (package
+ (name "rfkill")
+ (version "0.5")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://kernel.org/software/network/"
+ name "/" name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "0snqj5h0y991lszbigbyyqb8swj0hxajc1vfqg2scfay44231bp0"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:make-flags (list "CC=gcc"
+ (string-append "PREFIX=" %output))
+ #:phases (modify-phases %standard-phases
+ (delete 'configure))
+ #:tests? #f))
+ (home-page "https://wireless.wiki.kernel.org/en/users/Documentation/rfkill")
+ (synopsis "Tool for enabling and disabling wireless devices")
+ (description
+ "rfkill is a simple tool for accessing the rfkill device interface,
+which is used to enable and disable wireless networking devices, typically
+WLAN, Bluetooth and mobile broadband.")
+ (license (non-copyleft "file://COPYING"
+ "See COPYING in the distribution."))))
+
(define-public acpid
(package
(name "acpid")