summaryrefslogtreecommitdiff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2023-08-09 13:19:42 -0400
committerLeo Famulari <leo@famulari.name>2023-07-23 22:26:09 -0400
commitdb775e7367e8deffb513aad94f4afb875d796d0b (patch)
tree788542ca190bdd4607cf666c090458c074155939 /gnu/packages/linux.scm
parent8eefb81b773a400f49d79410656f72ff2bbc1602 (diff)
gnu: Remove linux-libre 6.3.
This kernel series is no longer supported upstream. * gnu/packages/linux.scm (linux-libre-6.3-version, linux-libre-6.3-gnu-revision, deblob-scripts-6.3, linux-libre-6.3-pristine-source, linux-libre-6.3-source, linux-libre-headers-6.3, linux-libre-6.3): Remove variables. * gnu/packages/aux-files/linux-libre/6.3-arm.conf, gnu/packages/aux-files/linux-libre/6.3-arm64.conf, gnu/packages/aux-files/linux-libre/6.3-i686.conf, gnu/packages/aux-files/linux-libre/6.3-x86_64.conf: Delete files. * Makefile.am (AUX_FILES): Remove them. * gnu/packages/patches/linux-libre-wireguard-postup-privkey.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Remove it.
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm35
1 files changed, 0 insertions, 35 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index d723a9cfaf..a88fb575a9 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -502,21 +502,6 @@ corresponding UPSTREAM-SOURCE (an origin), using the given DEBLOB-SCRIPTS."
(%upstream-linux-source version hash)
deblob-scripts-6.4)))
-(define-public linux-libre-6.3-version "6.3.13")
-(define-public linux-libre-6.3-gnu-revision "gnu")
-(define deblob-scripts-6.3
- (linux-libre-deblob-scripts
- linux-libre-6.3-version
- linux-libre-6.3-gnu-revision
- (base32 "01ivgzq18fwas87q84jx9jipcw58kwdnch7ylwg06d98ncga27px")
- (base32 "1i6vyakvqgmr3lcmr0aj8n7lbcksrp4d0rm1sz7cz64hwbsr67pq")))
-(define-public linux-libre-6.3-pristine-source
- (let ((version linux-libre-6.3-version)
- (hash (base32 "1ywijjhf19bciip75ppzjjh7bkadd449jr64yg2j5049w9h0aipa")))
- (make-linux-libre-source version
- (%upstream-linux-source version hash)
- deblob-scripts-6.3)))
-
;; The "longterm" kernels — the older releases with long-term upstream support.
;; Here are the support timelines:
;; <https://www.kernel.org/category/releases.html>
@@ -643,13 +628,6 @@ corresponding UPSTREAM-SOURCE (an origin), using the given DEBLOB-SCRIPTS."
(list %boot-logo-patch
%linux-libre-arm-export-__sync_icache_dcache-patch)))
-(define-public linux-libre-6.3-source
- (source-with-patches linux-libre-6.3-pristine-source
- (list %boot-logo-patch
- %linux-libre-arm-export-__sync_icache_dcache-patch
- (search-patch
- "linux-libre-wireguard-postup-privkey.patch"))))
-
(define-public linux-libre-6.1-source
(source-with-patches linux-libre-6.1-pristine-source
(append
@@ -768,11 +746,6 @@ corresponding UPSTREAM-SOURCE (an origin), using the given DEBLOB-SCRIPTS."
linux-libre-6.4-gnu-revision
linux-libre-6.4-source))
-(define-public linux-libre-headers-6.3
- (make-linux-libre-headers* linux-libre-6.3-version
- linux-libre-6.3-gnu-revision
- linux-libre-6.3-source))
-
(define-public linux-libre-headers-6.1
(make-linux-libre-headers* linux-libre-6.1-version
linux-libre-6.1-gnu-revision
@@ -1119,14 +1092,6 @@ Linux kernel. It has been modified to remove all non-free binary blobs.")
"aarch64-linux" "powerpc64le-linux" "riscv64-linux")
#:configuration-file kernel-config))
-(define-public linux-libre-6.3
- (make-linux-libre* linux-libre-6.3-version
- linux-libre-6.3-gnu-revision
- linux-libre-6.3-source
- '("x86_64-linux" "i686-linux" "armhf-linux"
- "aarch64-linux" "powerpc64le-linux" "riscv64-linux")
- #:configuration-file kernel-config))
-
(define-public linux-libre-version linux-libre-6.4-version)
(define-public linux-libre-gnu-revision linux-libre-6.4-gnu-revision)
(define-public linux-libre-pristine-source linux-libre-6.4-pristine-source)