summaryrefslogtreecommitdiff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
authorSimon Streit <simon@netpanic.org>2022-08-18 22:51:16 +0200
committerMathieu Othacehe <othacehe@gnu.org>2022-09-12 21:15:13 +0200
commite8636e09e1de820770a7ff17192bd70651d51bd8 (patch)
tree97ee68c1d1f241d587d6ffb5289945f35f16ada2 /gnu/packages/linux.scm
parent23b50ddbdbcee0dac1bc05f12374043d6f215b00 (diff)
gnu: Add tp-smapi-module.
* gnu/packages/linux.scm (tp-smapi-module): New variable. Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index be30716ea7..605325f924 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -9335,3 +9335,30 @@ desktop.")
directly from the kernel device and prints a device description and the events
with the value and the symbolic name.")
(license license:gpl2+)))
+
+(define-public tp-smapi-module
+ (package
+ (name "tp-smapi-module")
+ (version "0.43")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/linux-thinkpad/tp_smapi")
+ (commit (string-append "tp-smapi/" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1rjb0njckczc2mj05cagvj0lkyvmyk6bw7wkiinv81lw8m90g77g"))))
+ (build-system linux-module-build-system)
+ (arguments
+ `(#:tests? #f)) ;there are none.
+ (home-page "https://github.com/linux-thinkpad/tp_smapi")
+ (synopsis
+ "Linux Kernel module exposing features of ThinkPad hardware")
+ (description
+ "This package provides a Linux Kernel module that allows to control
+battery charging of specific ThinkPad laptops. It also includes an improved
+version of the HDAPS driver. The underlying hardware interfaces are
+@acronym{SMAPI, System Management Application Program Interface} and direct
+access to the embedded controller.")
+ (license license:gpl2+)))