summaryrefslogtreecommitdiff
path: root/gnu/packages/lisp-xyz.scm
diff options
context:
space:
mode:
authorjgart <jgart@dismail.de>2023-02-17 18:25:17 +0100
committerGuillaume Le Vaillant <glv@posteo.net>2023-02-17 19:18:49 +0100
commit17e46bdf66acee5191ba212ef86557f38c5b9d62 (patch)
tree97ba0d9c92fa893d60fd49be0daf44d2f07cd576 /gnu/packages/lisp-xyz.scm
parent7679b8e89572d469eea464b9a1ba23ca7b38fcf3 (diff)
gnu: Add cl-special-functions.
* gnu/packages/lisp-xyz.scm (cl-special-functions, ecl-special-functions, sbcl-special-functions): New variables. Signed-off-by: Guillaume Le Vaillant <glv@posteo.net>
Diffstat (limited to 'gnu/packages/lisp-xyz.scm')
-rw-r--r--gnu/packages/lisp-xyz.scm42
1 files changed, 42 insertions, 0 deletions
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index c768ea7832..135569efd0 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -26961,6 +26961,48 @@ of Cephes special functions.")
(define-public ecl-cephes
(sbcl-package->ecl-package sbcl-cephes))
+(define-public sbcl-special-functions
+ (let ((commit "f3ca2792ff3f8351839c366413da6b1bb2965a58")
+ (revision "0"))
+ (package
+ (name "sbcl-special-functions")
+ (version (git-version "1.2.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/Lisp-Stat/special-functions")
+ (commit commit)))
+ (file-name (git-file-name "cl-special-functions" version))
+ (sha256
+ (base32 "092szffy7zfxgrvfck11wnj8l0mgcym13yiafj01ad02lbj1fnnv"))))
+ (build-system asdf-build-system/sbcl)
+ (native-inputs
+ (list sbcl-fiveam
+ sbcl-select
+ sbcl-cl-variates))
+ (inputs
+ (list sbcl-alexandria-plus
+ sbcl-float-features
+ sbcl-let-plus
+ sbcl-numerical-utilities))
+ (home-page "https://lisp-stat.dev/docs/resources/special-functions/")
+ (synopsis "Special functions in Common Lisp")
+ (description "This library implements
+@url{http://specialfunctionswiki.org/index.php/Main_Page, special
+functions} and has a focus on high accuracy double-float calculations
+using the latest algorithms.")
+ (license license:ms-pl))))
+
+(define-public cl-special-functions
+ (sbcl-package->cl-source-package sbcl-special-functions))
+
+(define-public ecl-special-functions
+ (package
+ (inherit (sbcl-package->ecl-package sbcl-special-functions))
+ ;; https://github.com/Lisp-Stat/special-functions/issues/4
+ (arguments (list #:tests? #f))))
+
;;;
;;; Avoid adding new packages to the end of this file. To reduce the chances
;;; of a merge conflict, place them above by existing packages with similar