summaryrefslogtreecommitdiff
path: root/gnu/packages/lisp-xyz.scm
diff options
context:
space:
mode:
authorPierre Neidhardt <mail@ambrevar.xyz>2022-07-04 21:46:56 +0200
committerGuillaume Le Vaillant <glv@posteo.net>2022-08-03 16:45:54 +0200
commit369377a0fb113b0f26fb518c7f8653cbd997e23a (patch)
tree605b3c27de88a5904cca0f081f53ffad9e277562 /gnu/packages/lisp-xyz.scm
parent81fe659aad194681068f847aa56504001e8da3e0 (diff)
gnu: sbcl-jzon: Enable tests.
* gnu/packages/lisp-xyz.scm (sbcl-jzon)[arguments]: Move test system to #:asd-test-systems. Add phase to fix test .asd to actually run the tests. Signed-off-by: Guillaume Le Vaillant <glv@posteo.net>
Diffstat (limited to 'gnu/packages/lisp-xyz.scm')
-rw-r--r--gnu/packages/lisp-xyz.scm14
1 files changed, 13 insertions, 1 deletions
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index bfde1e4e89..20841bd397 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -21391,7 +21391,19 @@ implementation for Common Lisp.")
(base32 "1048f6prz2lp859nxwcgghn6n38pc2pb580azzxpdhfcdi0034mj"))))
(build-system asdf-build-system/sbcl)
(arguments
- '(#:asd-systems '("com.inuoe.jzon" "com.inuoe.jzon-tests")))
+ '(#:asd-systems '("com.inuoe.jzon")
+ #:asd-test-systems '("com.inuoe.jzon-tests")
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'fix-test-asd
+ (lambda _
+ (substitute* "test/com.inuoe.jzon-tests.asd"
+ ((":depends-on")
+ (string-append
+ ":perform (test-op (op c) (symbol-call :fiveam :run!"
+ " (find-symbol \"JZON\" :com.inuoe.jzon-tests)))"
+ "\n"
+ " :depends-on"))))))))
(native-inputs
(list sbcl-alexandria
sbcl-fiveam