summaryrefslogtreecommitdiff
path: root/gnu/packages/lisp-xyz.scm
diff options
context:
space:
mode:
authorGuillaume Le Vaillant <glv@posteo.net>2024-05-30 18:07:10 +0200
committerGuillaume Le Vaillant <glv@posteo.net>2024-06-07 09:35:40 +0200
commit7df1df1489d0ca5a05eef13ee810a2633b11de93 (patch)
tree49d3d9cc8c169ae416d508a83c46d15575413033 /gnu/packages/lisp-xyz.scm
parent6aca9b80f4e36cf1358dc53af1ca4725eda61f5f (diff)
gnu: cl-specialization-store: Disable tests.
* gnu/packages/lisp-xyz.scm (sbcl-specialization-store)[arguments]: Disable tests. (ecl-specialization-store): Simplify package definition. Change-Id: I5dd574ac5e14a2c9a39e689af519cae45f6e59f5
Diffstat (limited to 'gnu/packages/lisp-xyz.scm')
-rw-r--r--gnu/packages/lisp-xyz.scm10
1 files changed, 5 insertions, 5 deletions
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index e73e735083..54c33cadcb 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -26816,6 +26816,10 @@ using the latest algorithms.")
(list sbcl-fiveam))
(inputs
(list sbcl-alexandria sbcl-introspect-environment))
+ (arguments
+ ;; FIXME: Tests fail with:
+ ;; Unable to compile test syntax-layer-test define-specialization/name.
+ (list #:tests? #f))
(home-page "https://github.com/markcox80/specialization-store")
(synopsis "Different type of generic function for Common Lisp")
(description
@@ -26828,11 +26832,7 @@ function.")
(sbcl-package->cl-source-package sbcl-specialization-store))
(define-public ecl-specialization-store
- (package
- (inherit (sbcl-package->ecl-package sbcl-specialization-store))
- (arguments
- ;; TODO: Find why the tests get stuck forever; disable them for now.
- `(#:tests? #f))))
+ (sbcl-package->ecl-package sbcl-specialization-store))
(define-public sbcl-specialized-function
(let ((commit "5e2b04432bdf728496e6ff7227f210f845af7247")