summaryrefslogtreecommitdiff
path: root/gnu/packages/lisp-xyz.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2021-06-13 12:05:30 +0100
committerGuillaume Le Vaillant <glv@posteo.net>2021-06-14 09:55:38 +0200
commitcb5ba97e1c6827431a3225093ee42dfc6a7c1e1c (patch)
tree1d7b8544e026a661943fa0b2ee509663fdb41e02 /gnu/packages/lisp-xyz.scm
parent7cf3860429f7ba650f0fe040310017b419b57961 (diff)
gnu: cl-specialized-function: Update to 0.1-3.5e2b044.
* gnu/packages/lisp-xyz.scm: (sbcl-specialized-function): Update to 0.1-3.5e2b044. [arguments]: Enable tests. Signed-off-by: Guillaume Le Vaillant <glv@posteo.net>
Diffstat (limited to 'gnu/packages/lisp-xyz.scm')
-rw-r--r--gnu/packages/lisp-xyz.scm24
1 files changed, 10 insertions, 14 deletions
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index f9b82e9c69..252797eafa 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -9854,20 +9854,20 @@ correctly.")
(sbcl-package->ecl-package sbcl-trivialib-type-unify))
(define-public sbcl-specialized-function
- (let ((commit "dee56d2d2b6ecd10500ad291c56217698604ec35")
- (revision "2"))
+ (let ((commit "5e2b04432bdf728496e6ff7227f210f845af7247")
+ (revision "3"))
(package
(name "sbcl-specialized-function")
- (version (git-version "0.0.0" revision commit))
+ (version (git-version "0.1" revision commit))
(source
(origin
(method git-fetch)
(uri (git-reference
(url "https://github.com/numcl/specialized-function")
(commit commit)))
- (file-name (git-file-name name version))
+ (file-name (git-file-name "specialized-function" version))
(sha256
- (base32 "1mcc7mmpbnmgnr1cl2jl5r1ai54gn7fbisv2c14sh9za5w4sib82"))))
+ (base32 "19hfgc83b7as630r1w9r8yl0v6xq3dn01vcrl0bd4pza5hgjn4la"))))
(build-system asdf-build-system/sbcl)
(synopsis "Julia-like dispatch for Common Lisp")
(description
@@ -9878,21 +9878,17 @@ code. The main target of this macro is speed.")
(home-page "https://github.com/numcl/specialized-function")
(license license:lgpl3+)
(inputs
- `(("trivia" ,sbcl-trivia)
- ("alexandria" ,sbcl-alexandria)
+ `(("alexandria" ,sbcl-alexandria)
("iterate" ,sbcl-iterate)
("lisp-namespace" ,sbcl-lisp-namespace)
- ("type-r" ,sbcl-type-r)
- ("trivial-cltl2" ,sbcl-trivial-cltl2)))
+ ("trivia" ,sbcl-trivia)
+ ("trivial-cltl2" ,sbcl-trivial-cltl2)
+ ("type-r" ,sbcl-type-r)))
(native-inputs
`(("fiveam" ,sbcl-fiveam)))
(arguments
`(#:asd-files '("specialized-function.asd")
- #:test-asd-file "specialized-function.test.asd"
- ;; Tests fail because they try to use an internal symbol of SBCL
- ;; that does not exists in recent versions:
- ;; "The variable SB-VM:COMPLEX-VECTOR-NIL-WIDETAG is unbound."
- #:tests? #f)))))
+ #:test-asd-file "specialized-function.test.asd")))))
(define-public cl-specialized-function
(sbcl-package->cl-source-package sbcl-specialized-function))