summaryrefslogtreecommitdiff
path: root/gnu/packages/lisp-xyz.scm
diff options
context:
space:
mode:
authorcage <cage-dev@twistfold.it>2023-05-15 19:55:27 +0200
committerGuillaume Le Vaillant <glv@posteo.net>2023-05-17 15:21:55 +0200
commited60a524fbb34b0b37799c556f2516c06d050af3 (patch)
tree2b01619d86f2640cdb3f4858fcba209ade12bb5e /gnu/packages/lisp-xyz.scm
parentcf82526ac400fe953ddfbf9d7458d62ea4871d10 (diff)
gnu: cl-croatoan: Update to 0.1.
* gnu/packages/lisp-xyz.scm (sbcl-croatoan): Update to 0.1. Signed-off-by: Guillaume Le Vaillant <glv@posteo.net>
Diffstat (limited to 'gnu/packages/lisp-xyz.scm')
-rw-r--r--gnu/packages/lisp-xyz.scm62
1 files changed, 30 insertions, 32 deletions
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 8bed746669..c8e8cd47e3 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -18512,39 +18512,37 @@ protocol for Mastodon.")
(sbcl-package->cl-source-package sbcl-tooter))
(define-public sbcl-croatoan
- (let ((commit "42e474f4dffe2f4e429905a612be5736c2c3e374")
- (revision "7"))
- (package
- (name "sbcl-croatoan")
- (version (git-version "0.0.1" revision commit))
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/McParen/croatoan")
- (commit commit)))
- (file-name (git-file-name "cl-croatoan" version))
- (sha256
- (base32 "12hnj8gwk2600j3kn778xvvpx3y6z0428v5dq2qbf4vbzj66vcxj"))))
- (build-system asdf-build-system/sbcl)
- (arguments
- '(#:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'fix-paths
- (lambda* (#:key inputs #:allow-other-keys)
- (substitute* "ncurses/ncurses.lisp"
- (("libncursesw.so")
- (search-input-file inputs "/lib/libncursesw.so"))))))))
- (inputs
- (list ncurses
- sbcl-cffi
- sbcl-trivial-gray-streams
- sbcl-bordeaux-threads))
- (synopsis "Common Lisp bindings for the ncurses terminal library")
- (description "Croatoan provides high-level Common Lisp CLOS bindings for
+ (package
+ (name "sbcl-croatoan")
+ (version "0.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/McParen/croatoan")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name "cl-croatoan" version))
+ (sha256
+ (base32 "1whbvwc4df7zz0002xy3aczrpf4s3vk6kmyh9wydgwl112h060pd"))))
+ (build-system asdf-build-system/sbcl)
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'fix-paths
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* "ncurses/ncurses.lisp"
+ (("libncursesw.so")
+ (search-input-file inputs "/lib/libncursesw.so"))))))))
+ (inputs
+ (list ncurses
+ sbcl-cffi
+ sbcl-trivial-gray-streams
+ sbcl-bordeaux-threads))
+ (synopsis "Common Lisp bindings for the ncurses terminal library")
+ (description "Croatoan provides high-level Common Lisp CLOS bindings for
the ncurses terminal library.")
- (home-page "https://github.com/McParen/croatoan")
- (license license:expat))))
+ (home-page "https://github.com/McParen/croatoan")
+ (license license:expat)))
(define-public ecl-croatoan
(sbcl-package->ecl-package sbcl-croatoan))