summaryrefslogtreecommitdiff
path: root/gnu/packages/lisp-xyz.scm
diff options
context:
space:
mode:
authorKatherine Cox-Buday <cox.katherine.e@gmail.com>2020-01-03 15:07:30 +0100
committerGuillaume Le Vaillant <glv@posteo.net>2020-01-03 20:45:42 +0100
commitedfa2261dcf0b7737399b8a509a81f542de6bbf1 (patch)
treed79c52574ba5319421a443579ca13962859e5f78 /gnu/packages/lisp-xyz.scm
parent14ef7a9292ae03fd0beb07b339741f4e93ea29bc (diff)
gnu: Add symbol-munger.
* gnu/packages/lisp-xyz.scm (sbcl-symbol-munger, cl-symbol-munger, ecl-symbol-munger): New variables. Signed-off-by: Guillaume Le Vaillant <glv@posteo.net>
Diffstat (limited to 'gnu/packages/lisp-xyz.scm')
-rw-r--r--gnu/packages/lisp-xyz.scm40
1 files changed, 40 insertions, 0 deletions
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index de3359ba9f..28dd7566b3 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -7729,3 +7729,43 @@ style of JUnit for Java. It is a new version of the lisp-unit library written
by Chris Riesbeck.")
(home-page "https://github.com/AccelerationNet/lisp-unit2")
(license license:expat))))
+
+(define-public sbcl-symbol-munger
+ (let ((commit "97598d4c3c53fd5da72ab78908fbd5d8c7a13416")
+ (revision "1"))
+ (package
+ (name "sbcl-symbol-munger")
+ (version (git-version "0.0.1" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/AccelerationNet/symbol-munger.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0y8jywjy0ldyhp7bxf16fdvdd2qgqnd7nlhlqfpfnzxcqk4xy1km"))))
+ (build-system asdf-build-system/sbcl)
+ (inputs
+ `(("alexandria" ,sbcl-alexandria)
+ ("iterate" ,sbcl-iterate)))
+ (native-inputs
+ `(("lisp-unit2-boot0" ,sbcl-lisp-unit2-boot0)))
+ (synopsis
+ "Capitalization and spacing conversion functions for Common Lisp")
+ (description
+ "This is a Common Lisp library to change the capitalization and spacing
+of a string or a symbol. It can convert to and from Lisp, english, underscore
+and camel-case rules.")
+ (home-page "https://github.com/AccelerationNet/symbol-munger")
+ ;; The package declares a BSD license, but all of the license
+ ;; text is MIT.
+ ;; See https://github.com/AccelerationNet/symbol-munger/issues/5
+ (license license:expat))))
+
+(define-public cl-symbol-munger
+ (sbcl-package->cl-source-package sbcl-symbol-munger))
+
+(define-public ecl-symbol-munger
+ (sbcl-package->ecl-package sbcl-symbol-munger))