summaryrefslogtreecommitdiff
path: root/gnu/packages/lisp-xyz.scm
diff options
context:
space:
mode:
authorGuillaume Le Vaillant <glv@posteo.net>2023-09-06 10:57:58 +0200
committerGuillaume Le Vaillant <glv@posteo.net>2023-09-06 10:57:58 +0200
commitee13af93b5f5a6bb3d79ef6c6f31ddc3c06d6faf (patch)
tree11291b6b0d185776c92ab106b0a2807e514b91a5 /gnu/packages/lisp-xyz.scm
parent17c13b4a423097506c9b8fb01ca34ce2ef2b932f (diff)
gnu: cl-virality: Update to 0.3.0-1.cdc19cc.
* gnu/packages/lisp-xyz.scm (sbcl-virality): Update to 0.3.0-1.cdc19cc. [arguments]: Update 'delete-examples' phase.
Diffstat (limited to 'gnu/packages/lisp-xyz.scm')
-rw-r--r--gnu/packages/lisp-xyz.scm115
1 files changed, 62 insertions, 53 deletions
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 69686dbed9..84ee45b4c9 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -22181,58 +22181,67 @@ fit together as required by any particular game.")
(sbcl-package->cl-source-package sbcl-trial))
(define-public sbcl-virality
- (package
- (name "sbcl-virality")
- (version "0.3.0")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/bufferswap/ViralityEngine")
- (commit (string-append "v" version))))
- (file-name (git-file-name "cl-virality" version))
- (sha256
- (base32 "0hvjcvyd628jh4if6swk1wrfb9qdlnpk9ax1y3jarr8ms7ghfcdb"))))
- (build-system asdf-build-system/sbcl)
- (arguments
- `(#:asd-systems '("virality"
- "vorigin"
- "vorigin.test"
- "vshadow"
- "vumbra"
- "vutils")
- #:phases (modify-phases %standard-phases
- (add-after 'unpack 'delete-examples
- (lambda _
- ;; Don't install the big "examples" directory.
- (delete-file-recursively "examples"))))))
- (inputs
- (list sbcl-3b-bmfont
- sbcl-babel
- sbcl-cl-cpus
- sbcl-cl-graph
- sbcl-cl-opengl
- sbcl-cl-ppcre
- sbcl-cl-slug
- sbcl-closer-mop
- sbcl-fast-io
- sbcl-global-vars
- sbcl-glsl-packing
- sbcl-jsown
- sbcl-lparallel
- sbcl-pngload
- sbcl-printv
- sbcl-queues
- sbcl-sdl2
- sbcl-serapeum
- sbcl-split-sequence
- sbcl-static-vectors
- sbcl-trivial-features
- sbcl-varjo))
- (home-page "https://github.com/bufferswap/ViralityEngine")
- (synopsis "Component-based game engine written in Common Lisp")
- (description
- "Virality Engine provides a system and workflow that helps describe the
+ (let ((commit "cdc19cca9b028f0c30d14ed8b3e51359dd46069a")
+ (revision "1"))
+ (package
+ (name "sbcl-virality")
+ (version (git-version "0.3.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/bufferswap/ViralityEngine")
+ (commit commit)))
+ (file-name (git-file-name "cl-virality" version))
+ (sha256
+ (base32 "1s25aapkqcr8fxi0i9wjw0n4jax7r4a9d9wflpr3sqz2vgrg2lz6"))))
+ (build-system asdf-build-system/sbcl)
+ (arguments
+ `(#:asd-systems '("virality"
+ "vorigin"
+ "vorigin.test"
+ "vshadow"
+ "vumbra"
+ "vutils")
+ #:phases (modify-phases %standard-phases
+ (add-after 'unpack 'delete-examples
+ (lambda _
+ ;; Don't install the big "examples" directory.
+ (delete-file-recursively "examples")
+ ;; Remove example asd files that cause issues during
+ ;; the 'copy-source' phase because they have the same
+ ;; names.
+ (for-each
+ delete-file
+ (find-files "."
+ "^xXx-SYSTEM-NAME-xXx\\.asd$")))))))
+ (inputs
+ (list sbcl-3b-bmfont
+ sbcl-babel
+ sbcl-cl-cpus
+ sbcl-cl-graph
+ sbcl-cl-opengl
+ sbcl-cl-ppcre
+ sbcl-cl-slug
+ sbcl-closer-mop
+ sbcl-fast-io
+ sbcl-global-vars
+ sbcl-glsl-packing
+ sbcl-jsown
+ sbcl-lparallel
+ sbcl-pngload
+ sbcl-printv
+ sbcl-queues
+ sbcl-sdl2
+ sbcl-serapeum
+ sbcl-split-sequence
+ sbcl-static-vectors
+ sbcl-trivial-features
+ sbcl-varjo))
+ (home-page "https://github.com/bufferswap/ViralityEngine")
+ (synopsis "Component-based game engine written in Common Lisp")
+ (description
+ "Virality Engine provides a system and workflow that helps describe the
elements needed to write 2D or 3D games. It was designed with several domain
specific languages that make it easier to describe, manipulate, and use assets
commonly found in game making. Such assets include (but are not limited to)
@@ -22246,7 +22255,7 @@ can be used with them. Components are added to Actors which represent game
concepts like players, scenery, effects, etc. We define a component protocol
invoked by Virality Engine to move your components to the next state and
render them each frame.")
- (license license:expat)))
+ (license license:expat))))
(define-public cl-virality
(sbcl-package->cl-source-package sbcl-virality))