summaryrefslogtreecommitdiff
path: root/gnu/packages/llvm.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-11-30 12:33:46 +0200
committerEfraim Flashner <efraim@flashner.co.il>2023-11-30 12:33:46 +0200
commitf4735ccf9bb5ff521215e9ffa60244a585be3446 (patch)
tree4e5a665608c9743eba493b9a927bf52c46a784d6 /gnu/packages/llvm.scm
parent0bf46a4fc8c8d2c9b7dfba1211e42d8af62a3b55 (diff)
gnu: libclc: Update to 15.0.7.
* gnu/packages/llvm.scm (libclc): Update to 15.0.7. [source]: Use the llvm-monorepo. [arguments]: Remove configure-flag for python, add one for llvm-spirv. Add a phase to skip 2 tests. Remove trailing #t from phases. [propagated-inputs]: Add spirv-llvm-translator, spirv-tools. [native-inputs]: Replace clang-9 with 15, llvm-9 with 15. [properties]: Add release-monitoring-url. Change-Id: I06e2e7be0dc5733a2cc17429928b1761ab987906
Diffstat (limited to 'gnu/packages/llvm.scm')
-rw-r--r--gnu/packages/llvm.scm47
1 files changed, 24 insertions, 23 deletions
diff --git a/gnu/packages/llvm.scm b/gnu/packages/llvm.scm
index 6bd52969e6..d0a5e1b71b 100644
--- a/gnu/packages/llvm.scm
+++ b/gnu/packages/llvm.scm
@@ -73,6 +73,7 @@
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages python)
#:use-module (gnu packages swig)
+ #:use-module (gnu packages vulkan)
#:use-module (gnu packages xml)
#:use-module (srfi srfi-1)
#:use-module (ice-9 match)
@@ -1946,37 +1947,37 @@ standard C++ library.")
(define-public libclc
(package
(name "libclc")
- (version "9.0.1")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/llvm/llvm-project")
- (commit (string-append "llvmorg-" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "1d1qayvrvvc1di7s7jfxnjvxq2az4lwq1sw1b2gq2ic0nksvajz0"))))
+ (version (package-version llvm-15))
+ (source (llvm-monorepo version))
(build-system cmake-build-system)
(arguments
- `(#:configure-flags
- (list (string-append "-DLLVM_CLANG="
- (assoc-ref %build-inputs "clang")
- "/bin/clang")
- (string-append "-DPYTHON="
- (assoc-ref %build-inputs "python")
- "/bin/python3"))
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'chdir
- (lambda _ (chdir "libclc") #t)))))
+ (list
+ #:configure-flags
+ #~(list (string-append "-DLLVM_CLANG="
+ (assoc-ref %build-inputs "clang")
+ "/bin/clang")
+ (string-append "-DLLVM_SPIRV="
+ (assoc-ref %build-inputs "spirv-llvm-translator")
+ "/bin/llvm-spirv"))
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'enter-subdirectory
+ (lambda _
+ (chdir "libclc")))
+ (add-after 'enter-subdirectory 'skip-clspv-tests
+ (lambda _
+ (substitute* "CMakeLists.txt"
+ (("ptx\\.\\*") "[ptx|clspv].*")))))))
+ (propagated-inputs
+ (list spirv-llvm-translator spirv-tools))
(native-inputs
- (list clang-9 llvm-9 python))
+ (list clang-15 llvm-15 python))
(home-page "https://libclc.llvm.org")
(synopsis "Libraries for the OpenCL programming language")
(description
"This package provides an implementation of the OpenCL library
requirements according to version 1.1 of the OpenCL specification.")
+ (properties `((release-monitoring-url . ,%llvm-release-monitoring-url)))
;; Apache license 2.0 with LLVM exception
(license license:asl2.0)))