summaryrefslogtreecommitdiff
path: root/gnu/packages/loko.scm
diff options
context:
space:
mode:
authorZhu Zihao <all_but_last@163.com>2022-11-29 18:59:24 +0800
committerLudovic Courtès <ludo@gnu.org>2022-12-02 23:11:10 +0100
commit1f5241d8d5913ec5edf30cd4b00f6e7e4228881d (patch)
treedbc4f0b5f5db4a854ce5f9884b9e612e005b8d99 /gnu/packages/loko.scm
parent9672db290a35f59113682a7f0c17c050a4ae2578 (diff)
gnu: loko-scheme: Use G-expressions.
* gnu/packages/loko.scm (loko-scheme)[arguments]: Use G-expressions. <#:phases>: In 'akku-fixes', replace "(assoc-ref inputs name)" with "this-package-native-input". [native-inputs]: Use label-less style. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/loko.scm')
-rw-r--r--gnu/packages/loko.scm72
1 files changed, 38 insertions, 34 deletions
diff --git a/gnu/packages/loko.scm b/gnu/packages/loko.scm
index 449c62f1f0..cb189acb87 100644
--- a/gnu/packages/loko.scm
+++ b/gnu/packages/loko.scm
@@ -41,41 +41,45 @@
(file-name (git-file-name name version))))
(build-system gnu-build-system)
(arguments
- `(;; r7rs tests are a work in progress as of 0.7.0.
- #:tests? #f
- #:strip-binaries? #f
- #:make-flags
- (let ((out (assoc-ref %outputs "out")))
- (list
- (string-append "PREFIX=" out)
- (string-append "GDB_AUTOLOAD_PATH=" out "/share/gdb/auto-load")))
- #:phases
- (modify-phases %standard-phases
- (delete 'configure)
- (add-before 'build 'akku-fixes
- (lambda* (#:key inputs #:allow-other-keys)
- (delete-file "Akku.lock")
- (substitute* "Akku.manifest"
- (("\\(depends.*") "(depends)"))
- (invoke "akku" "install")
- (let ((dest "./.akku/lib/")
- (source "/share/guile/site/3.0/"))
- (for-each
- (lambda (name)
- ;; Symlink the scheme libraries so that Akku can find them
- (symlink (string-append (assoc-ref inputs name) source name)
- (string-append dest name)))
- '("struct" "laesare" "pfds" "machine-code")))
- (substitute* ".akku/env"
- (("/bin/sh") (which "sh")))
- #t)))))
+ (list
+ ;; r7rs tests are a work in progress as of 0.7.0.
+ #:tests? #f
+ #:strip-binaries? #f
+ #:make-flags
+ #~(list
+ (string-append "PREFIX=" #$output)
+ (string-append "GDB_AUTOLOAD_PATH=" #$output "/share/gdb/auto-load"))
+ #:phases
+ #~(modify-phases %standard-phases
+ (delete 'configure)
+ (add-before 'build 'akku-fixes
+ (lambda _
+ (delete-file "Akku.lock")
+ (substitute* "Akku.manifest"
+ (("\\(depends.*") "(depends)"))
+ (invoke "akku" "install")
+ (let ((dest "./.akku/lib/")
+ (source "/share/guile/site/3.0/"))
+ (for-each
+ (lambda (name prefix)
+ ;; Symlink the scheme libraries so that Akku can find them
+ (symlink (string-append prefix source name)
+ (string-append dest name)))
+ '("struct" "laesare" "pfds" "machine-code")
+ (list #$(this-package-native-input "guile-struct-pack")
+ #$(this-package-native-input "guile-laesare")
+ #$(this-package-native-input "guile-pfds")
+ #$(this-package-native-input "guile-machine-code"))))
+ (substitute* ".akku/env"
+ (("/bin/sh") (which "sh")))
+ #t)))))
(native-inputs
- `(("akku" ,akku)
- ("chez-scheme" ,(chez-scheme-for-system))
- ("struct" ,guile-struct-pack)
- ("laesare" ,guile-laesare)
- ("pfds" ,guile-pfds)
- ("machine-code" ,guile-machine-code)))
+ (list akku
+ (chez-scheme-for-system)
+ guile-struct-pack
+ guile-laesare
+ guile-pfds
+ guile-machine-code))
(home-page "https://scheme.fail")
(synopsis "Implementation of the algorithmic language Scheme")
(description