summaryrefslogtreecommitdiff
path: root/gnu/packages/lxqt.scm
diff options
context:
space:
mode:
authorMeiyo Peng <meiyo.peng@gmail.com>2018-10-18 11:40:41 +0800
committer宋文武 <iyzsong@member.fsf.org>2018-10-24 22:37:24 +0800
commit2bdab26f06d5b1767400ad7688e4b37e1b628a0c (patch)
treeaec8c276fb6ce98d2b41b31f994a1d47857cac14 /gnu/packages/lxqt.scm
parentd6fd4a76eb81d2aedaa51a78e29b9b96312d03f9 (diff)
gnu: Add lxqt-about.
* gnu/packages/lxqt.scm (lxqt-about): New variable. Signed-off-by: 宋文武 <iyzsong@member.fsf.org>
Diffstat (limited to 'gnu/packages/lxqt.scm')
-rw-r--r--gnu/packages/lxqt.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/lxqt.scm b/gnu/packages/lxqt.scm
index ee48494308..467240af09 100644
--- a/gnu/packages/lxqt.scm
+++ b/gnu/packages/lxqt.scm
@@ -237,6 +237,39 @@ to statistics about the system on which it's run.")
and memory usage or network traffic.")
(license lgpl2.1+)))
+(define-public lxqt-about
+ (package
+ (name "lxqt-about")
+ (version "0.13.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/lxqt/" name "/releases/download/"
+ version "/" name "-" version ".tar.xz"))
+ (sha256
+ (base32 "08imj7p77ifzfxnn8c482mhrvfx9gi0rb43ab5rw1rkmfvax2n5w"))))
+ (build-system cmake-build-system)
+ (inputs
+ `(("kwindowsystem" ,kwindowsystem)
+ ("liblxqt" ,liblxqt)
+ ("libqtxdg" ,libqtxdg)
+ ("qtbase" ,qtbase)
+ ("qtsvg" ,qtsvg)
+ ("qtx11extras" ,qtx11extras)))
+ (native-inputs
+ `(("lxqt-build-tools" ,lxqt-build-tools)
+ ("qttools" ,qttools)))
+ (arguments
+ '(#:tests? #f ; no tests
+ #:configure-flags
+ ;; TODO: prefetch translations files from 'lxqt-l10n'.
+ '("-DPULL_TRANSLATIONS=NO")))
+ (home-page "https://lxqt.org")
+ (synopsis "Provides information about LXQt and the system")
+ (description "lxqt-about is a dialogue window providing information about
+LXQt and the system it's running on.")
+ (license lgpl2.1+)))
+
(define-public lxqt-build-tools
(package
(name "lxqt-build-tools")