summaryrefslogtreecommitdiff
path: root/gnu/packages/lxqt.scm
diff options
context:
space:
mode:
author宋文武 <iyzsong@member.fsf.org>2022-08-17 11:08:22 +0800
committer宋文武 <iyzsong@member.fsf.org>2022-08-22 08:42:54 +0800
commita79afa8d38f37f541b2ff9b6f52776d4d4fa8de9 (patch)
tree363877cc96e5d893c982ac03a7458a419c14a16b /gnu/packages/lxqt.scm
parentda546ff3b911157c13e07246027a4fcffbd66cc5 (diff)
gnu: lxqt-themes: Update to 1.1.0.
* gnu/packages/lxqt.scm (lxqt-themes): Update to 1.1.0. [arguments]: Remove phases.
Diffstat (limited to 'gnu/packages/lxqt.scm')
-rw-r--r--gnu/packages/lxqt.scm18
1 files changed, 3 insertions, 15 deletions
diff --git a/gnu/packages/lxqt.scm b/gnu/packages/lxqt.scm
index 5b3625bd08..0f123e5a2d 100644
--- a/gnu/packages/lxqt.scm
+++ b/gnu/packages/lxqt.scm
@@ -786,30 +786,18 @@ permissions of other users including root.")
(define-public lxqt-themes
(package
(name "lxqt-themes")
- (version "0.17.0")
+ (version "1.1.0")
(source
(origin
(method url-fetch)
(uri (string-append "https://github.com/lxqt/" name "/releases/download/"
version "/" name "-" version ".tar.xz"))
(sha256
- (base32 "0kmvcz6rxghxxgb0m264zbvycc1zjma8mr4cpwg5kyrzb47rdw9z"))))
+ (base32 "18zrp2j0xpsrzy6m2dw8k55zczcc9jzavncasrp5j1dxscnzwrcr"))))
(build-system cmake-build-system)
(native-inputs
(list lxqt-build-tools))
- (arguments
- `(#:tests? #f ; no tests
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'patch-source
- (lambda _
- (substitute* '("CMakeLists.txt")
- (("DESTINATION \"\\$\\{LXQT_GRAPHICS_DIR\\}")
- "DESTINATION \"share/lxqt/graphics"))
- (substitute* '("themes/CMakeLists.txt")
- (("DESTINATION \"\\$\\{LXQT_SHARE_DIR\\}")
- "DESTINATION \"share/lxqt"))
- #t)))))
+ (arguments '(#:tests? #f)) ; no tests
(home-page "https://lxqt-project.org")
(synopsis "Themes, graphics and icons for LXQt")
(description "This package comprises a number of graphic files and themes