summaryrefslogtreecommitdiff
path: root/gnu/packages/machine-learning.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2023-10-25 16:47:41 +0200
committerRicardo Wurmus <rekado@elephly.net>2023-10-25 16:58:40 +0200
commit8027b0a26940fd16da714a0437b71edb41cd5700 (patch)
tree00681e84f49ab999fa7392befba39368f14c1f29 /gnu/packages/machine-learning.scm
parent136700181ba61cf9ab44ce6e64e09a30415bc870 (diff)
gnu: Add python-funsor.
* gnu/packages/machine-learning.scm (python-funsor): New variable. Change-Id: Ibd4b993e4d55a6fdda70fe2b6cf4f665730b6739
Diffstat (limited to 'gnu/packages/machine-learning.scm')
-rw-r--r--gnu/packages/machine-learning.scm36
1 files changed, 36 insertions, 0 deletions
diff --git a/gnu/packages/machine-learning.scm b/gnu/packages/machine-learning.scm
index 16781b7aa1..26a8c97a4a 100644
--- a/gnu/packages/machine-learning.scm
+++ b/gnu/packages/machine-learning.scm
@@ -151,6 +151,42 @@ representations and sentence classification.")
(inputs (list fasttext))
(native-inputs (list pybind11))))
+(define-public python-funsor
+ (package
+ (name "python-funsor")
+ (version "0.4.5")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "funsor" version))
+ (sha256
+ (base32 "0cgysij0dix0fikyz2x4f8jvaskm5s5a04s07chzaz2dw1fpxdq8"))))
+ (build-system pyproject-build-system)
+ (propagated-inputs (list python-makefun python-multipledispatch
+ python-numpy python-opt-einsum
+ python-typing-extensions))
+ (native-inputs (list python-black
+ python-flake8
+ python-isort
+ python-nbsphinx
+ python-pandas
+ python-pillow
+ python-pyro-api
+ python-pytest
+ python-pytest-xdist
+ python-requests
+ python-scipy
+ python-sphinx
+ python-sphinx-gallery
+ python-sphinx-rtd-theme
+ python-torchvision))
+ (home-page "https://github.com/pyro-ppl/funsor")
+ (synopsis "Tensor-like library for functions and distributions")
+ (description
+ "This package provides a tensor-like library for functions and
+distributions.")
+ (license license:asl2.0)))
+
(define-public fann
;; The last release is >100 commits behind, so we package from git.
(let ((commit "d71d54788bee56ba4cf7522801270152da5209d7"))