summaryrefslogtreecommitdiff
path: root/gnu/packages/machine-learning.scm
diff options
context:
space:
mode:
authorVinicius Monego <monego@posteo.net>2023-05-20 21:48:47 -0300
committerVinicius Monego <monego@posteo.net>2023-09-16 23:10:52 -0300
commit9b78699744b0c4c8af28820cc4f0d59b9d317ead (patch)
tree38dcabc9fe0c39fc5279456114f9a51b110f9f95 /gnu/packages/machine-learning.scm
parentc7bd5811da38509762609eb8dcae90ed9b610421 (diff)
gnu: Add python-gpytorch.
* gnu/packages/machine-learning.scm (python-gpytorch): New variable.
Diffstat (limited to 'gnu/packages/machine-learning.scm')
-rw-r--r--gnu/packages/machine-learning.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/machine-learning.scm b/gnu/packages/machine-learning.scm
index 717c52345c..f351586214 100644
--- a/gnu/packages/machine-learning.scm
+++ b/gnu/packages/machine-learning.scm
@@ -4597,6 +4597,37 @@ inference.")
linear algebra routines needed for structured matrices (or operators).")
(license license:expat)))
+(define-public python-gpytorch
+ (package
+ (name "python-gpytorch")
+ (version "1.11")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "gpytorch" version))
+ (sha256
+ (base32
+ "0q17bml53vixk3cwj3p893809927hz81fprwsmxpxqv5i4mvgyvj"))))
+ (build-system pyproject-build-system)
+ (arguments
+ (list #:test-flags
+ ;; The error message in test_t_matmul_matrix suggests the error may
+ ;; be due to a bug in gpytorch. test_deprecated_methods fails with
+ ;; an AssertionError.
+ #~(list "-k" (string-append "not test_deprecated_methods"
+ " and not test_t_matmul_matrix"))))
+ (propagated-inputs (list python-linear-operator python-scikit-learn))
+ (native-inputs (list python-coverage
+ python-flake8
+ python-flake8-print
+ python-nbval
+ python-pytest
+ python-twine))
+ (home-page "https://gpytorch.ai")
+ (synopsis "Implementation of Gaussian Processes in PyTorch")
+ (description
+ "GPyTorch is a Gaussian process library implemented using PyTorch.")
+ (license license:expat)))
+
(define-public vosk-api
(let* ((openfst openfst-for-vosk)
(kaldi kaldi-for-vosk))