summaryrefslogtreecommitdiff
path: root/gnu/packages/machine-learning.scm
diff options
context:
space:
mode:
authorArun Isaac <arunisaac@systemreboot.net>2023-11-20 18:48:50 +0000
committerArun Isaac <arunisaac@systemreboot.net>2023-11-20 18:48:50 +0000
commitee49611771e73aebcab92972b856dc91761ac77f (patch)
tree2c498d73bfec1e6521514f9245d1d5862962efbf /gnu/packages/machine-learning.scm
parent8ebd4beb97f9e1f2ac2efde9ffc1c6bc7a8993a1 (diff)
gnu: python-imbalanced-learn: Reformat with guix style.
* gnu/packages/machine-learning.scm (python-imbalanced-learn): Reformat with guix style. Change-Id: Ifbdcb8dc43433bd6b4777527d5f8f94d5e1aa168
Diffstat (limited to 'gnu/packages/machine-learning.scm')
-rw-r--r--gnu/packages/machine-learning.scm64
1 files changed, 31 insertions, 33 deletions
diff --git a/gnu/packages/machine-learning.scm b/gnu/packages/machine-learning.scm
index a84377e1eb..b5bf9aa5fe 100644
--- a/gnu/packages/machine-learning.scm
+++ b/gnu/packages/machine-learning.scm
@@ -1664,44 +1664,42 @@ and forecasting.")
(package
(name "python-imbalanced-learn")
(version "0.9.1")
- (source (origin
- (method url-fetch)
- (uri (pypi-uri "imbalanced-learn" version))
- (sha256
- (base32
- "0qnrmysnqpc8ii1w5n8mci20gcjhmjr7khvk7f2apdbqc2pgf52f"))))
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "imbalanced-learn" version))
+ (sha256
+ (base32 "0qnrmysnqpc8ii1w5n8mci20gcjhmjr7khvk7f2apdbqc2pgf52f"))))
(build-system pyproject-build-system)
(arguments
(list
- #:phases
- '(modify-phases %standard-phases
- (add-after 'unpack 'unbreak-tests
- (lambda _
- ;; The doctests require tensorflow
- (substitute* "setup.cfg"
- (("--doctest-modules") ""))
- ;; Some tests require a home directory
- (setenv "HOME" (getcwd))
- ;; We don't have keras
- (delete-file "imblearn/keras/tests/test_generator.py")
- ;; We don't have tensorflow
- (delete-file "imblearn/tensorflow/tests/test_generator.py"))))))
- (propagated-inputs
- (list python-joblib
- python-numpy
- python-scikit-learn
- python-scipy
- python-threadpoolctl))
- (native-inputs
- (list python-black
- python-flake8
- python-mypy
- python-pandas
- python-pytest
- python-pytest-cov))
+ #:phases '(modify-phases %standard-phases
+ (add-after 'unpack 'unbreak-tests
+ (lambda _
+ ;; The doctests require tensorflow
+ (substitute* "setup.cfg"
+ (("--doctest-modules")
+ ""))
+ ;; Some tests require a home directory
+ (setenv "HOME"
+ (getcwd))
+ ;; We don't have keras
+ (delete-file "imblearn/keras/tests/test_generator.py")
+ ;; We don't have tensorflow
+ (delete-file
+ "imblearn/tensorflow/tests/test_generator.py"))))))
+ (propagated-inputs (list python-joblib python-numpy python-scikit-learn
+ python-scipy python-threadpoolctl))
+ (native-inputs (list python-black
+ python-flake8
+ python-mypy
+ python-pandas
+ python-pytest
+ python-pytest-cov))
(home-page "https://github.com/scikit-learn-contrib/imbalanced-learn")
(synopsis "Toolbox for imbalanced dataset in machine learning")
- (description "This is a Python package offering a number of re-sampling
+ (description
+ "This is a Python package offering a number of re-sampling
techniques commonly used in datasets showing strong between-class imbalance.
It is compatible with @code{scikit-learn}.")
(license license:expat)))