summaryrefslogtreecommitdiff
path: root/gnu/packages/mail.scm
diff options
context:
space:
mode:
authorSébastien Lerique <sl@eauchat.org>2020-09-14 10:44:34 +0200
committerLudovic Courtès <ludo@gnu.org>2020-09-14 23:04:10 +0200
commit0d63abebd149de0c5261ea12cbf7d5850ace5aee (patch)
treef39fda24f9677054ee707b65cf2379eb3b45e83b /gnu/packages/mail.scm
parent6cb573889b1ca183c1c0c1ddcb191b919e6c1ea8 (diff)
gnu: Add ripmime.
* gnu/packages/mail.scm (ripmime): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/mail.scm')
-rw-r--r--gnu/packages/mail.scm48
1 files changed, 48 insertions, 0 deletions
diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index 2244653724..3e6d975ee4 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -690,6 +690,54 @@ mailpack. What can alterMIME do?
(license (list (license:non-copyleft "file://LICENSE")
license:bsd-3))))
+(define-public ripmime
+ ;; Upstream does not tag or otherwise provide any releases (only a version
+ ;; number in the source)
+ (let ((commit "a556ffe08d620602475c976732e8e1a82f3169e9")
+ (revision "1"))
+ (package
+ (name "ripmime")
+ (version (git-version "1.4.0.10" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/inflex/ripMIME")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1z8ar8flvkd9q3ax4x28sj5pyq8ykk5pq249y967lj2406lxparh"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ ;; Source has no configure script
+ (delete 'configure)
+ ;; Buildcodes make the build non-reproducible; remove them
+ (add-after 'unpack 'strip-buildcodes
+ (lambda _
+ (substitute* "generate-buildcodes.sh"
+ (("`date \\+%s`") "0")
+ (("`date`") "0")
+ (("`uname -a`") "Guix"))
+ #t))
+ ;; https://github.com/inflex/ripMIME/pull/16 makes 'mkdir-p-bin-man unnecessary
+ (add-before 'install 'mkdir-p-bin-man
+ (lambda _
+ (mkdir-p (string-append (assoc-ref %outputs "out") "/bin"))
+ (mkdir-p (string-append (assoc-ref %outputs "out") "/man"))
+ #t)))
+ ;; Makefile has no tests
+ #:tests? #f
+ #:make-flags (list (string-append "LOCATION=" (assoc-ref %outputs "out"))
+ "CC=gcc")))
+ (synopsis "Extract attachments from MIME-encoded email")
+ (description
+ "ripMIME is a small program to extract the attached files out of a
+MIME-encoded email package.")
+ (home-page "https://github.com/inflex/ripMIME")
+ (license license:bsd-3))))
+
(define-public bogofilter
(package
(name "bogofilter")