summaryrefslogtreecommitdiff
path: root/gnu/packages/markup.scm
diff options
context:
space:
mode:
authorVinicius Monego <monego@posteo.net>2024-03-24 09:24:29 -0300
committerVinicius Monego <monego@posteo.net>2024-03-31 07:37:17 -0300
commit43ed834127efb86282856e0e3940735de94bee39 (patch)
tree69e60f36eb5bc8e3a7b647e71655a75e1c43daaa /gnu/packages/markup.scm
parent76ed1e886ea790fc8562b355a0768a0f04889abb (diff)
gnu: python-mistletoe: Update to 1.3.0.
* gnu/packages/markup.scm (python-mistletoe): Update to 1.3.0. [build-system]: Use pyproject-build-system. [arguments]: Do not override the check phase, skip one test in #:test-flags. [native-inputs]: Add python-parameterized, python-pytest. Change-Id: If25e3cbe19d8936d150c830f1b8f4ce8f8cb5692
Diffstat (limited to 'gnu/packages/markup.scm')
-rw-r--r--gnu/packages/markup.scm18
1 files changed, 8 insertions, 10 deletions
diff --git a/gnu/packages/markup.scm b/gnu/packages/markup.scm
index 375367d395..6d891ee313 100644
--- a/gnu/packages/markup.scm
+++ b/gnu/packages/markup.scm
@@ -10,7 +10,7 @@
;;; Copyright © 2021 Zhu Zihao <all_but_last@163.com>
;;; Copyright © 2021 Petr Hodina <phodina@protonmail.com>
;;; Copyright © 2022 jgart <jgart@dismail.de>
-;;; Copyright © 2022 Vinicius Monego <monego@posteo.net>
+;;; Copyright © 2022, 2024 Vinicius Monego <monego@posteo.net>
;;; Copyright © 2023 Zheng Junjie <873216071@qq.com>
;;;
;;; This file is part of GNU Guix.
@@ -39,6 +39,7 @@
#:use-module (guix build-system cmake)
#:use-module (guix build-system perl)
#:use-module (guix build-system python)
+ #:use-module (guix build-system pyproject)
#:use-module (guix utils)
#:use-module (guix gexp)
#:use-module (gnu packages)
@@ -475,21 +476,18 @@ with a few extensions.")
(define-public python-mistletoe
(package
(name "python-mistletoe")
- (version "0.8.1")
+ (version "1.3.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "mistletoe" version))
(sha256
- (base32 "0h8ydzxlfzmspiz8lcm13qp720kfsxiky0qqnc2mxf4qzm16m326"))))
- (build-system python-build-system)
+ (base32 "1sfv79fway4iya9i3rmz1bkj12lhzgazd4n7kv8phi4vvn57h3mx"))))
+ (build-system pyproject-build-system)
(arguments
- `(#:phases
- (modify-phases %standard-phases
- (replace 'check
- (lambda* (#:key tests? #:allow-other-keys)
- (when tests?
- (invoke "python" "-m" "unittest" "discover" "test")))))))
+ ;; FileNotFoundError (not distributed in PyPI).
+ (list #:test-flags #~(list "-k" "not test_main")))
+ (native-inputs (list python-parameterized python-pytest))
(home-page "https://github.com/miyuchina/mistletoe")
(synopsis "Extensible Markdown parser in pure Python")
(description