summaryrefslogtreecommitdiff
path: root/gnu/packages/mate.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2022-11-21 23:27:38 +0100
committerLudovic Courtès <ludo@gnu.org>2022-11-22 09:43:54 +0100
commit47ba3f7d25fadb12b78d2728941e4e677fd7ad0e (patch)
tree1c31fd3ef51583fb07a3178b5d1e7d26a9fa9f76 /gnu/packages/mate.scm
parent3954780bfb99af3034622c24332dcb13b95fb5d6 (diff)
gnu: mate: Depend on gnome-keyring only on supported systems.
This lets us build Mate on i686-linux. * gnu/packages/mate.scm (mate)[inputs]: Add GNOME-KEYRING conditionally.
Diffstat (limited to 'gnu/packages/mate.scm')
-rw-r--r--gnu/packages/mate.scm87
1 files changed, 45 insertions, 42 deletions
diff --git a/gnu/packages/mate.scm b/gnu/packages/mate.scm
index d0e73e5a47..ce62366985 100644
--- a/gnu/packages/mate.scm
+++ b/gnu/packages/mate.scm
@@ -1490,48 +1490,51 @@ used to bring up authentication dialogs.")
(native-inputs (list desktop-file-utils))
(inputs
;; TODO: Add more packages
- (list at-spi2-core
- atril
- caja
- dbus
- dconf
- engrampa
- eom
- font-abattis-cantarell
- glib-networking
- gnome-keyring
- gvfs
- hicolor-icon-theme
- libmatekbd
- libmateweather
- libmatemixer
- marco
- mate-session-manager
- mate-settings-daemon
- mate-desktop
- mate-terminal
- mate-themes
- mate-icon-theme
- mate-power-manager
- mate-menus
- mate-panel
- mate-control-center
- mate-media
- mate-applets
- mate-user-guide
- mate-calc
- mate-backgrounds
- mate-netbook
- mate-utils
- mate-polkit
- mate-system-monitor
- mate-utils
- pluma
- pinentry-gnome3
- pulseaudio
- shared-mime-info
- yelp
- zenity))
+ (append (if (or (%current-target-system)
+ (supported-package? gnome-keyring))
+ (list gnome-keyring)
+ '())
+ (list at-spi2-core
+ atril
+ caja
+ dbus
+ dconf
+ engrampa
+ eom
+ font-abattis-cantarell
+ glib-networking
+ gvfs
+ hicolor-icon-theme
+ libmatekbd
+ libmateweather
+ libmatemixer
+ marco
+ mate-session-manager
+ mate-settings-daemon
+ mate-desktop
+ mate-terminal
+ mate-themes
+ mate-icon-theme
+ mate-power-manager
+ mate-menus
+ mate-panel
+ mate-control-center
+ mate-media
+ mate-applets
+ mate-user-guide
+ mate-calc
+ mate-backgrounds
+ mate-netbook
+ mate-utils
+ mate-polkit
+ mate-system-monitor
+ mate-utils
+ pluma
+ pinentry-gnome3
+ pulseaudio
+ shared-mime-info
+ yelp
+ zenity)))
(propagated-inputs
;; Default font that applications such as IceCat require.
(list font-dejavu))