summaryrefslogtreecommitdiff
path: root/gnu/packages/maths.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2022-12-08 12:06:47 +0200
committerEfraim Flashner <efraim@flashner.co.il>2022-12-08 19:53:16 +0200
commit02d591206259b30462764cb2f978ae214dea0449 (patch)
tree4622c1683b0c32a677700326bcefb249cc247b22 /gnu/packages/maths.scm
parent7d8f92dd87e6f13ec6b87744c3db9bb3be541707 (diff)
gnu: julia: Update to 1.8.3.
* gnu/packages/julia.scm (julia): Update to 1.8.3. [source]: Remove one patch. [arguments]: Adjust 'prepare-deps phase to changes in inputs. Remove custom 'use-system-libwhich, 'change-number-of-precompiled-statements, 'symlink-libraries phases. In 'fix-include-and-link-paths phase remove substitution for utf8proc linking and adjust libuv linking. Fix reference to shell in 'replace-default-shell phase. Adjust the 'shared-objects-path phase to changes in the source. Change the 'enable-parallel-tests phase for upstream changes. Adjust the 'adjust-test-suite phase to be more robust. Change the 'disable-broken-tests phase to help the test suite pass. Rename 'symlink-llvm-utf8proc phase to 'symlink-missing-libraries and add two more. Adjust make-flags for changes in shared system libraries. Reorder make-flags to changes in the source. Except for aarch64, use the defaults for choosing to use 64-bit blas. [inputs]: Add libblastrampoline. Replace libgit-1.1 with libgit-1.3, utf8proc-2.7.1 with utf8proc-2.8.0. [native-inputs]: Replace python-2 with python. (libunwind-julia): Update to 1.5.0. [source]: Update patches. * gnu/packages/libevent.scm (libuv-julia): Update to 2.0.0-4.e6f0e49. [arguments]: Also build static library, build position-independent-code. * gnu/packages/llvm.scm (llvm-julia): Update to llvm-13, following upstream's build instructions. * gnu/packages/maths.scm (openlibm): Update to 0.8.1. * gnu/packages/textutils.scm (utf8proc-2.7.1): Update and rename to utf8proc-2.8.0. [native-inputs]: Update unicode to 14.0.0. * gnu/packages/tls.scm (mbedtls-apache): Update to 2.28.0. [source]: Remove snippet. [arguments]: Remove trailing #t from phases. * gnu/packages/patches/julia-allow-parallel-build.patch, (julia-patch): Update version string to 1.8.2. gnu/packages/patches/libunwind-julia-fix-GCC10-fno-common.patch: Remove files. * gnu/local.mk (dist_patch_DATA): Remove them. Co-authored-by: Akira Kyle <akira@akirakyle.com>
Diffstat (limited to 'gnu/packages/maths.scm')
-rw-r--r--gnu/packages/maths.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index e2236f0f70..27b8eaf60d 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -4853,7 +4853,7 @@ access to BLIS implementations via traditional BLAS routine calls.")
(define-public openlibm
(package
(name "openlibm")
- (version "0.7.4")
+ (version "0.8.1")
(source
(origin
(method git-fetch)
@@ -4862,7 +4862,7 @@ access to BLIS implementations via traditional BLAS routine calls.")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "1azms0lpxb7vxb3bln5lyz0wpwx6jnzbffkclclpq2v5aiw8d14i"))))
+ (base32 "1xsrcr49z0wdqpwd98jmw2xh18myzsa9xman0kp1h2i89x8mic5b"))))
(build-system gnu-build-system)
(arguments
`(#:make-flags