summaryrefslogtreecommitdiff
path: root/gnu/packages/maths.scm
diff options
context:
space:
mode:
authorRomain GARBAGE <romain.garbage@inria.fr>2024-03-11 12:06:55 +0100
committerLudovic Courtès <ludo@gnu.org>2024-04-04 16:17:33 +0200
commit17c9c0052194637e50f9fa24e96ed600157ccd90 (patch)
tree9cc5adb94699ff04feee68f1e6487e57e7e502b6 /gnu/packages/maths.scm
parent03951f5a6642b78523d51f3f537fce646d224eda (diff)
gnu: ipopt: Switch to openblas.
* gnu/packages/maths.scm (ipopt): Switch input dependency from lapack to openblas and add required configure flags. Change-Id: I58b84f0741a973adf81da1716e2e2659af1c50c4 Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/maths.scm')
-rw-r--r--gnu/packages/maths.scm7
1 files changed, 4 insertions, 3 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 75addc6c7d..3c589d31c8 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -2400,7 +2400,8 @@ online as well as original implementations of various other algorithms.")
"08gznhwhqv1x4baksz350ih8q16r5rd0k8vals6078m3h94khr4b"))))
(build-system gnu-build-system)
(arguments
- '(#:phases (modify-phases %standard-phases
+ '(#:configure-flags (list "--with-lapack=-lopenblas")
+ #:phases (modify-phases %standard-phases
(add-after 'install 'add--L-flags-in-ipopt.pc
(lambda* (#:key inputs outputs #:allow-other-keys)
;; The '.pc' file lists '-llapack -lblas' in "Libs";
@@ -2413,14 +2414,14 @@ online as well as original implementations of various other algorithms.")
(("Libs: (.*)-llapack -lblas(.*)$" _ before after)
(string-append "Libs: " before " " after "\n"
"Libs.private: " before
- "-L" lapack "/lib -llapack -lblas "
+ "-L" openblas "/lib -lopenblas"
after "\n")))
#t))))))
(native-inputs
(list gfortran pkg-config))
(inputs
;; TODO: Maybe add dependency on COIN-MUMPS, ASL, and HSL.
- (list lapack)) ;for both libblas and liblapack
+ (list openblas)) ;for both libblas and liblapack
(home-page "https://www.coin-or.org")
(synopsis "Large-scale nonlinear optimizer")
(description