summaryrefslogtreecommitdiff
path: root/gnu/packages/maths.scm
diff options
context:
space:
mode:
authorPaul A. Patience <paul@apatience.com>2022-07-25 15:12:24 +0000
committerLudovic Courtès <ludo@gnu.org>2022-08-01 17:20:27 +0200
commit18d998ffdb8a64478f984bac479734e3fcc90cc3 (patch)
treed7ef78d9dc8338b192dca3778d5ead4459629263 /gnu/packages/maths.scm
parent32bcadc98c146d373db20c4154cd0acfb12de6e1 (diff)
gnu: trilinos-for-dealii-openmpi: Use G-expressions.
* gnu/packages/maths.scm (trilinos-for-dealii-openmpi)[arguments]: Use G-expressions. <#:phases>: Remove trailing boolean. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/maths.scm')
-rw-r--r--gnu/packages/maths.scm162
1 files changed, 83 insertions, 79 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index e3cc3c993e..8d71bf324f 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -5182,85 +5182,89 @@ revised simplex and the branch-and-bound methods.")
(propagated-inputs
(list openmpi))
(arguments
- `(#:build-type "Release"
- #:configure-flags
- `("-DBUILD_SHARED_LIBS=ON"
- ;; Obtain the equivalent of RelWithDebInfo but with -O3 (the Release
- ;; default) rather than -O2 (the RelWithDebInfo default), to conform
- ;; to candi's trilinos.package's compilation flags, which are -g -O3.
- "-DCMAKE_C_FLAGS=-g"
- "-DCMAKE_CXX_FLAGS=-g"
- "-DCMAKE_Fortran_FLAGS=-g"
-
- ;; Trilinos libraries that deal.II can interface with.
- "-DTrilinos_ENABLE_Amesos=ON"
- "-DTrilinos_ENABLE_AztecOO=ON"
- "-DTrilinos_ENABLE_Epetra=ON"
- "-DTrilinos_ENABLE_EpetraExt=ON"
- "-DTrilinos_ENABLE_Ifpack=ON"
- "-DTrilinos_ENABLE_ML=ON"
- "-DTrilinos_ENABLE_MueLu=ON"
- "-DTrilinos_ENABLE_ROL=ON"
- ;; Optional; required for deal.II's GridIn::read_exodusii, but
- ;; depends on netcdf.
- ;; Enable if and when someone needs it.
- ;;"-DTrilinos_ENABLE_SEACAS=ON"
- "-DTrilinos_ENABLE_Sacado=ON"
- "-DTrilinos_ENABLE_Teuchos=ON"
- "-DTrilinos_ENABLE_Tpetra=ON"
- "-DTrilinos_ENABLE_Zoltan=ON"
-
- ;; Third-party libraries (TPLs) that Trilinos can interface with.
- "-DBLAS_LIBRARY_NAMES=openblas"
- "-DTPL_ENABLE_MPI=ON"
- "-DTPL_ENABLE_MUMPS=ON"
- "-DTPL_ENABLE_SCALAPACK=ON"
-
- ;; Enable the tests but not the examples (which are enabled by
- ;; default when enabling tests).
- ;; Although some examples are run as tests, they are otherwise
- ;; unnecessary since this is a private package meant for
- ;; dealii-openmpi.
- ;; Besides, some MueLu and ROL examples require a lot of memory to
- ;; compile.
- ;;
- ;; (For future reference, note that some ROL and SEACAS examples
- ;; require removing gfortran from CPLUS_INCLUDE_PATH as in the
- ;; dune-istl, dune-localfunctions and dune-alugrid packages.)
- "-DTrilinos_ENABLE_TESTS=ON"
- "-DTrilinos_ENABLE_EXAMPLES=OFF"
- ;; MueLu tests require considerably more time and memory to compile
- ;; than the rest of the tests.
- "-DMueLu_ENABLE_TESTS=OFF"
-
- ;; The following options were gleaned from candi's trilinos.package.
- ;; (We do not enable the complex instantiations, which are anyway
- ;; provided only as an option in trilinos.package, because they are
- ;; costly in compilation time and memory usage, and disk space [1].)
- ;;
- ;; [1]: https://www.docs.trilinos.org/files/TrilinosBuildReference.html#enabling-float-and-complex-scalar-types
- "-DTrilinos_ENABLE_Ifpack2=OFF"
- "-DTeuchos_ENABLE_FLOAT=ON"
- "-DTpetra_INST_INT_LONG=ON"
- "-DTPL_ENABLE_Boost=OFF")
- #:phases
- (modify-phases %standard-phases
- (add-after 'configure 'fix-kokkos-config
- (lambda _
- ;; GNU Make 4.3 accidentally leaves the backslash preceding the
- ;; number sign in strings containing a literal backslash–number
- ;; sign (\#) [1, 2].
- ;; This is still an issue in Trilinos 13.0.1, but should be fixed
- ;; in the following version.
- ;; (The latest versions of Kokkos incorporate the fix [2].)
- ;;
- ;; [1]: https://github.com/GEOSX/thirdPartyLibs/issues/136
- ;; [2]: https://github.com/kokkos/kokkos/blob/3.4.00/Makefile.kokkos#L441
- (substitute* "KokkosCore_config.h"
- (("\\\\#") "#"))
- #t))
- (add-before 'check 'mpi-setup
- ,%openmpi-setup))))
+ (list #:build-type "Release"
+ #:configure-flags
+ #~(list "-DBUILD_SHARED_LIBS=ON"
+ ;; Obtain the equivalent of RelWithDebInfo but with -O3
+ ;; (the Release default) rather than -O2 (the
+ ;; RelWithDebInfo default), to conform to candi's
+ ;; trilinos.package's compilation flags, which are -g -O3.
+ "-DCMAKE_C_FLAGS=-g"
+ "-DCMAKE_CXX_FLAGS=-g"
+ "-DCMAKE_Fortran_FLAGS=-g"
+
+ ;; Trilinos libraries that deal.II can interface with.
+ "-DTrilinos_ENABLE_Amesos=ON"
+ "-DTrilinos_ENABLE_AztecOO=ON"
+ "-DTrilinos_ENABLE_Epetra=ON"
+ "-DTrilinos_ENABLE_EpetraExt=ON"
+ "-DTrilinos_ENABLE_Ifpack=ON"
+ "-DTrilinos_ENABLE_ML=ON"
+ "-DTrilinos_ENABLE_MueLu=ON"
+ "-DTrilinos_ENABLE_ROL=ON"
+ ;; Optional; required for deal.II's GridIn::read_exodusii,
+ ;; but depends on netcdf.
+ ;; Enable if and when someone needs it.
+ ;;"-DTrilinos_ENABLE_SEACAS=ON"
+ "-DTrilinos_ENABLE_Sacado=ON"
+ "-DTrilinos_ENABLE_Teuchos=ON"
+ "-DTrilinos_ENABLE_Tpetra=ON"
+ "-DTrilinos_ENABLE_Zoltan=ON"
+
+ ;; Third-party libraries (TPLs) that Trilinos can interface
+ ;; with.
+ "-DBLAS_LIBRARY_NAMES=openblas"
+ "-DTPL_ENABLE_MPI=ON"
+ "-DTPL_ENABLE_MUMPS=ON"
+ "-DTPL_ENABLE_SCALAPACK=ON"
+
+ ;; Enable the tests but not the examples (which are enabled
+ ;; by default when enabling tests).
+ ;; Although some examples are run as tests, they are
+ ;; otherwise unnecessary since this is a private package
+ ;; meant for dealii-openmpi.
+ ;; Besides, some MueLu and ROL examples require a lot of
+ ;; memory to compile.
+ ;;
+ ;; (For future reference, note that some ROL and SEACAS
+ ;; examples require removing gfortran from
+ ;; CPLUS_INCLUDE_PATH as in the dune-istl,
+ ;; dune-localfunctions and dune-alugrid packages.)
+ "-DTrilinos_ENABLE_TESTS=ON"
+ "-DTrilinos_ENABLE_EXAMPLES=OFF"
+ ;; MueLu tests require considerably more time and memory to
+ ;; compile than the rest of the tests.
+ "-DMueLu_ENABLE_TESTS=OFF"
+
+ ;; The following options were gleaned from candi's
+ ;; trilinos.package.
+ ;; (We do not enable the complex instantiations, which are
+ ;; anyway provided only as an option in trilinos.package,
+ ;; because they are costly in compilation time and memory
+ ;; usage, and disk space [1].)
+ ;;
+ ;; [1]: https://www.docs.trilinos.org/files/TrilinosBuildReference.html#enabling-float-and-complex-scalar-types
+ "-DTrilinos_ENABLE_Ifpack2=OFF"
+ "-DTeuchos_ENABLE_FLOAT=ON"
+ "-DTpetra_INST_INT_LONG=ON"
+ "-DTPL_ENABLE_Boost=OFF")
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'configure 'fix-kokkos-config
+ (lambda _
+ ;; GNU Make 4.3 accidentally leaves the backslash preceding
+ ;; the number sign in strings containing a literal
+ ;; backslash–number sign (\#) [1, 2].
+ ;; This is still an issue in Trilinos 13.0.1, but should be
+ ;; fixed in the following version.
+ ;; (The latest versions of Kokkos incorporate the fix [2].)
+ ;;
+ ;; [1]: https://github.com/GEOSX/thirdPartyLibs/issues/136
+ ;; [2]: https://github.com/kokkos/kokkos/blob/3.4.00/Makefile.kokkos#L441
+ (substitute* "KokkosCore_config.h"
+ (("\\\\#") "#"))))
+ (add-before 'check 'mpi-setup
+ #$%openmpi-setup))))
(home-page "https://trilinos.github.io/")
(synopsis "Algorithms for engineering and scientific problems")
(description