summaryrefslogtreecommitdiff
path: root/gnu/packages/maths.scm
diff options
context:
space:
mode:
authorPaul A. Patience <paul@apatience.com>2022-05-02 13:28:46 +0000
committerLudovic Courtès <ludo@gnu.org>2022-05-03 18:02:27 +0200
commit4c509a73b7aaf1416749f027c2e86a54347ad2b1 (patch)
treee821d0f1203f9c13ed7c62d0026e3df59942ca5c /gnu/packages/maths.scm
parent0d3c2c954393d0344e11ba0532e276cecb9ef2fb (diff)
gnu: sundials-openmpi: Add HYPRE dependency.
* gnu/packages/maths.scm (sundials-openmpi)[propagated-inputs]: Add hypre-openmpi. [arguments]<#:configure-flags>: Add -DENABLE_HYPRE, -DHYPRE_INCLUDE_DIR and -DHYPRE_LIBRARY_DIR. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/maths.scm')
-rw-r--r--gnu/packages/maths.scm9
1 files changed, 8 insertions, 1 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 5d4778da83..03c465dfff 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -6175,12 +6175,19 @@ easily be incorporated into existing simulation codes.")
(propagated-inputs
(list openmpi
;; Support for the below requires MPI.
- ;; TODO: Add HYPRE.
+ hypre-openmpi
petsc-openmpi))
(arguments
(substitute-keyword-arguments (package-arguments sundials)
((#:configure-flags flags '())
`(cons* "-DENABLE_MPI:BOOL=ON"
+ "-DENABLE_HYPRE:BOOL=ON"
+ (string-append "-DHYPRE_INCLUDE_DIR="
+ (assoc-ref %build-inputs "hypre-openmpi")
+ "/include")
+ (string-append "-DHYPRE_LIBRARY_DIR="
+ (assoc-ref %build-inputs "hypre-openmpi")
+ "/lib")
"-DENABLE_PETSC:BOOL=ON"
(string-append "-DPETSC_DIR="
(assoc-ref %build-inputs "petsc-openmpi"))