summaryrefslogtreecommitdiff
path: root/gnu/packages/maths.scm
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-03 12:51:49 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:16:47 +0200
commit7a18bd9e74b56a04ec7e4e120789e91d78830444 (patch)
tree2f245364b9bc842cd22adb37d792c99ba02b3a88 /gnu/packages/maths.scm
parentf37146969a2f24530fcdf270b2d19602809cb4ae (diff)
gnu: Rationalize texlive-updmap.cfg and texlive-tiny inputs.
TEXLIVE-UPDMAP.CFG and TEXLIVE-TINY should only be used as native inputs. Also remove texlive packages already provided by them. * doc/build.scm (pdf-manual): * gnu/packages/algebra.scm (pari-gp): * gnu/packages/bioinformatics.scm (discrover): (phyml): (velvet): * gnu/packages/chemistry.scm (yaehmop): * gnu/packages/chez.scm (stex-bootstrap): (chez-web): (chez-sockets): * gnu/packages/cran.scm (r-prereg): * gnu/packages/docbook.scm (dblatex): * gnu/packages/emacs-xyz.scm (emacs-auctex): * gnu/packages/engineering.scm (fastcap): * gnu/packages/fsf.scm (book-faif): * gnu/packages/graphviz.scm (dot2tex): * gnu/packages/maths.scm (hypre): * gnu/packages/ocaml.scm (unison): (ocaml-bibtex2html): * gnu/packages/plotutils.scm (asymptote): * gnu/packages/python-xyz.scm (python-nbconvert): (python-pypandoc): * gnu/packages/radio.scm (gnuradio): (libosmo-dsp): * gnu/packages/statistics.scm (r-with-tests): * gnu/packages/tex.scm (texlive-makecmds): (texlive-innerscript): (teximpatient): (texlive-xkeyval): Remove texlive packages already provided by TEXLIVE-UPDMAP.CFG. Don't add TEXLIVE-TINY or TEXLIVE-UPDMAP.CFG as inputs.
Diffstat (limited to 'gnu/packages/maths.scm')
-rw-r--r--gnu/packages/maths.scm82
1 files changed, 38 insertions, 44 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 5083b5bb6b..27ded198d0 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -5777,50 +5777,44 @@ set.")
python
python-breathe
python-sphinx
- (texlive-updmap.cfg (list texlive-adjustbox
- texlive-alphalph
- texlive-amsfonts
- texlive-bibtex
- texlive-capt-of
- texlive-caption
- texlive-cm
- texlive-cmap
- texlive-colortbl
- texlive-courier
- texlive-enumitem
- texlive-etoc
- texlive-etoolbox
- texlive-fancyhdr
- texlive-fancyvrb
- texlive-float
- texlive-fncychap
- texlive-framed
- texlive-geometry
- texlive-hanging
- texlive-helvetic
- texlive-hyperref
- texlive-jknapltx
- texlive-latexmk
- texlive-listofitems
- texlive-multirow
- texlive-natbib
- texlive-needspace
- texlive-newunicodechar
- texlive-parskip
- texlive-sectsty
- texlive-stackengine
- texlive-tabulary
- texlive-tex-gyre
- texlive-titlesec
- texlive-tocloft
- texlive-ulem
- texlive-upquote
- texlive-varwidth
- texlive-wasy
- texlive-wasysym
- texlive-wrapfig
- texlive-xcolor
- texlive-xypic))))
+ (texlive-updmap.cfg
+ (list texlive-adjustbox
+ texlive-alphalph
+ texlive-capt-of
+ texlive-caption
+ texlive-cmap
+ texlive-courier
+ texlive-enumitem
+ texlive-etoc
+ texlive-etoolbox
+ texlive-fancyvrb
+ texlive-float
+ texlive-fncychap
+ texlive-framed
+ texlive-hanging
+ texlive-helvetic
+ texlive-jknapltx
+ texlive-latexmk
+ texlive-listofitems
+ texlive-multirow
+ texlive-natbib
+ texlive-needspace
+ texlive-newunicodechar
+ texlive-parskip
+ texlive-sectsty
+ texlive-stackengine
+ texlive-tabulary
+ texlive-tex-gyre
+ texlive-titlesec
+ texlive-tocloft
+ texlive-ulem
+ texlive-upquote
+ texlive-varwidth
+ texlive-wasy
+ texlive-wasysym
+ texlive-wrapfig
+ texlive-xcolor
+ texlive-xypic))))
(inputs
(list openblas lapack))
(arguments