summaryrefslogtreecommitdiff
path: root/gnu/packages/maths.scm
diff options
context:
space:
mode:
authorPaul A. Patience <paul@apatience.com>2022-07-19 16:35:00 +0000
committerEfraim Flashner <efraim@flashner.co.il>2022-08-02 20:49:56 +0300
commita53bc4003682d9371fb8beda6d202e9a8c9556f2 (patch)
treebd5084a4c8c2bb50c441e33012edd7017835c503 /gnu/packages/maths.scm
parent44c7098809e1f9293ffb6b92bfcf7251332ea84d (diff)
gnu: gnuplot: Use G-expressions.
* gnu/packages/maths.scm (gnuplot)[arguments]: Use G-expressions. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu/packages/maths.scm')
-rw-r--r--gnu/packages/maths.scm11
1 files changed, 6 insertions, 5 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index c647c06c8a..777486227f 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -1134,11 +1134,12 @@ in the terminal or with an external viewer.")
(list pkg-config texlive-tiny))
(inputs
(list cairo gd lua pango readline))
- (arguments `(#:configure-flags (list (string-append
- "--with-texdir=" %output
- "/texmf-local/tex/latex/gnuplot"))
- ;; Plot on a dumb terminal during tests.
- #:make-flags '("GNUTERM=dumb")))
+ (arguments
+ (list #:configure-flags
+ #~(list (string-append "--with-texdir=" #$output
+ "/texmf-local/tex/latex/gnuplot"))
+ ;; Plot on a dumb terminal during tests.
+ #:make-flags #~'("GNUTERM=dumb")))
(home-page "http://www.gnuplot.info")
(synopsis "Command-line driven graphing utility")
(description "Gnuplot is a portable command-line driven graphing