summaryrefslogtreecommitdiff
path: root/gnu/packages/maths.scm
diff options
context:
space:
mode:
authorPaul A. Patience <paul@apatience.com>2022-07-25 15:11:54 +0000
committerLudovic Courtès <ludo@gnu.org>2022-08-01 17:20:26 +0200
commitbbf5e033d466b12c555e88434bd3d236ff9e6f4d (patch)
tree15b70a0f8a006d2b4f4a09b5053a572248889d2e /gnu/packages/maths.scm
parentc6800aa31efbda2590bc75a96595e8bce3cce41e (diff)
gnu: trilinos-for-dealii-openmpi: Fix build.
* gnu/packages/maths.scm (trilinos-for-dealii-openmpi)[native-inputs]: Add gcc-7 to fix the failing build with newer versions of gcc. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/maths.scm')
-rw-r--r--gnu/packages/maths.scm5
1 files changed, 4 insertions, 1 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 0795222ca8..6c789622f8 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -5152,7 +5152,10 @@ revised simplex and the branch-and-bound methods.")
(base32 "0fnwlhzsh85qj38cq3igbs8nm1b2jdgr2z734sapmyyzsy21mkgp"))))
(build-system cmake-build-system)
(native-inputs
- `(("gfortran" ,gfortran)
+ `(;; The build fails with the current gcc.
+ ;; Use the version from when Trilinos was added.
+ ("gcc" ,gcc-7)
+ ("gfortran" ,gfortran)
;; Trilinos's repository contains several C-shell scripts, but adding
;; tcsh to the native inputs does not result in the check phase running
;; any more tests than without it (nor is tcsh required to build