summaryrefslogtreecommitdiff
path: root/gnu/packages/maths.scm
diff options
context:
space:
mode:
authorPaul A. Patience <paul@apatience.com>2023-10-10 14:20:46 +0000
committerMathieu Othacehe <othacehe@gnu.org>2023-10-25 11:59:59 +0200
commitc6d2bb9d0a1e7e74af3984b7dad1ffacff20768c (patch)
tree1d25aaf6696cce96cb59731bc865bc67c11fdc9a /gnu/packages/maths.scm
parentefe9e0ce0cccee468ad7640e5cda9edebf504dab (diff)
gnu: gnuplot: Update to 5.4.9.
* gnu/packages/maths.scm (gnuplot): Update to 5.4.9. [arguments]<#:configure-flags>: Add --with-qt=no. Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
Diffstat (limited to 'gnu/packages/maths.scm')
-rw-r--r--gnu/packages/maths.scm7
1 files changed, 4 insertions, 3 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 6a3edbd465..3c511bd77c 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -1301,14 +1301,14 @@ in the terminal or with an external viewer.")
(define-public gnuplot
(package
(name "gnuplot")
- (version "5.4.8")
+ (version "5.4.9")
(source (origin
(method url-fetch)
(uri (string-append "mirror://sourceforge/gnuplot/gnuplot/"
version "/gnuplot-"
version ".tar.gz"))
(sha256
- (base32 "1kzmj4yyxvlxqzqbrw6sx6dnvhj1zzqnciyb8ryzy6mdrb3pj4lk"))))
+ (base32 "15vabi30s4ln4vi82csx4nvfms3ik8704rk0prcm9h1xylhs0a53"))))
(build-system gnu-build-system)
(native-inputs
(list pkg-config (texlive-updmap.cfg)))
@@ -1316,7 +1316,8 @@ in the terminal or with an external viewer.")
(list cairo gd lua pango readline))
(arguments
(list #:configure-flags
- #~(list (string-append "--with-texdir=" #$output
+ #~(list "--with-qt=no"
+ (string-append "--with-texdir=" #$output
"/texmf-local/tex/latex/gnuplot"))
;; Plot on a dumb terminal during tests.
#:make-flags #~'("GNUTERM=dumb")))