summaryrefslogtreecommitdiff
path: root/gnu/packages/maths.scm
diff options
context:
space:
mode:
authorNicolas Graves <ngraves@ngraves.fr>2023-11-06 00:51:45 +0100
committerLudovic Courtès <ludo@gnu.org>2023-11-23 12:56:42 +0100
commitd2a4beaf04d90fd26495ac6e05ddc2cae1a96524 (patch)
treeedaf81b133c3f430d253a5a21a3b567289829955 /gnu/packages/maths.scm
parent5b910b4f7cf5f994d42fffb107109808678b706c (diff)
gnu: scilab: Activate tests and disable failing tests.
* gnu/packages/maths.scm (scilab): Activate tests and disable failing tests. [arguments]: (tests?): Activate tests. (phases): [remove-desktop-files]: Extend and rename to restrain-to-scilab-cli. [disable-failing-tests]: Add phase. Change-Id: Icfec349c6efe14e7787ba8d385e5d51f82be82ea Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/maths.scm')
-rw-r--r--gnu/packages/maths.scm33
1 files changed, 25 insertions, 8 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 750de949b7..6b208d188a 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -9627,8 +9627,6 @@ computation is supported via MPI.")
tk))
(arguments
(list
- ;; The tests require java code.
- #:tests? #f
#:configure-flags
#~(list
"--enable-relocatable"
@@ -9668,12 +9666,31 @@ computation is supported via MPI.")
"modules/scicos/src/translator/makefile.mak"
"modules/scicos/src/modelica_compiler/makefile.mak")
(("nums\\.cmx?a") ""))))
- ;; Install only scilab-cli.desktop
- (add-after 'unpack 'remove-desktop-files
- (lambda _
- (substitute* "desktop/Makefile.am"
- (("desktop_DATA =")
- "desktop_DATA = scilab-cli.desktop\nDUMMY ="))))
+ (add-after 'unpack 'restrain-to-scilab-cli
+ (lambda _
+ ;; Install only scilab-cli.desktop
+ (substitute* "desktop/Makefile.am"
+ (("desktop_DATA =")
+ "desktop_DATA = scilab-cli.desktop\nDUMMY ="))
+ ;; Replace scilab with scilab-cli for tests.
+ (substitute* "Makefile.incl.am"
+ (("scilab-bin") "scilab-cli-bin")
+ (("scilab -nwni") "scilab-cli")
+ ;; Do not install tests, demos and examples.
+ ;; This saves up to 140 Mo in the final output.
+ (("(TESTS|DEMOS|EXAMPLES)_DIR=.*" all kind)
+ (string-append kind "_DIR=")))))
+ (add-before 'check 'disable-failing-tests
+ (lambda _
+ (substitute* "Makefile"
+ (("TESTS = .*")
+ "TESTS =\n"))
+ (substitute* "modules/functions_manager/Makefile"
+ (("check:.*")
+ "check:\n"))
+ (substitute* "modules/types/Makefile"
+ (("\\$\\(MAKE\\) \\$\\(AM_MAKEFLAGS\\) check-am")
+ ""))))
;; These generated files are assumed to be present during
;; the build.
(add-after 'bootstrap 'bootstrap-dynamic_link-scripts