summaryrefslogtreecommitdiff
path: root/gnu/packages/maths.scm
diff options
context:
space:
mode:
authorEric Bavier <bavier@cray.com>2018-03-02 14:05:34 -0600
committerEric Bavier <bavier@member.fsf.org>2018-04-26 20:54:18 -0500
commitd98e9009a934f7c12e2241b072ad469a009468de (patch)
tree83c65185884453a11c5b5f6ef26ee252882c79f1 /gnu/packages/maths.scm
parentc2e76b7082ee5af27765b0d3ac50810e076fe514 (diff)
gnu: scotch: Update to 6.0.5a.
* gnu/packages/patches/pt-scotch-build-parallelism.patch: Delete files. * gnu/packages/patches/scotch-build-parallelism.patch, gnu/packages/patches/scotch-graph-diam-64.patch, gnu/packages/patches/scotch-graph-induce-type-64.patch: New files. * gnu/local.mk (dist_patch_DATA): Adjust accordingly. * gnu/packages/maths.scm (scotch): Update to 6.0.5a. [source](patches): Adjust accordingly.
Diffstat (limited to 'gnu/packages/maths.scm')
-rw-r--r--gnu/packages/maths.scm8
1 files changed, 5 insertions, 3 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 353aa41167..aa382cda6b 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -2199,16 +2199,18 @@ implemented in ANSI C, and MPI for communications.")
(define-public scotch
(package
(name "scotch")
- (version "6.0.4")
+ (version "6.0.5a")
(source
(origin
(method url-fetch)
(uri (string-append "https://gforge.inria.fr/frs/download.php/"
"latestfile/298/scotch_" version ".tar.gz"))
(sha256
- (base32 "1ir088mvrqggyqdkx9qfynmiaffqbyih5qfl5mga2nrlm1qlsgzm"))
+ (base32 "0vsmgjz8qv80di3ljmc7hbdsizxxxwy2b9rgd2fl1mdc6dgbj8av"))
(patches (search-patches "scotch-test-threading.patch"
- "pt-scotch-build-parallelism.patch"))))
+ "scotch-build-parallelism.patch"
+ "scotch-graph-induce-type-64.patch"
+ "scotch-graph-diam-64.patch"))))
(build-system gnu-build-system)
(inputs
`(("zlib" ,zlib)