summaryrefslogtreecommitdiff
path: root/gnu/packages/maths.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-08-16 20:56:38 +0200
committerMarius Bakke <mbakke@fastmail.com>2018-08-16 20:56:38 +0200
commitdf570bf271536399993b39e7ea2ea0452bb6cde4 (patch)
tree32cde458f90c599691831fc33cfbd4efcca9e9eb /gnu/packages/maths.scm
parent37d203985e2817b0962129384e8b993a1bb92de9 (diff)
parent5f9a9945b5747e5ec284f8b116b2e8cc1b9064d7 (diff)
Merge branch 'master' into staging
Diffstat (limited to 'gnu/packages/maths.scm')
-rw-r--r--gnu/packages/maths.scm18
1 files changed, 9 insertions, 9 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 50de120e07..793693f31a 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -167,14 +167,14 @@ interactive dialogs to guide them.")
(define-public coda
(package
(name "coda")
- (version "2.18.3")
+ (version "2.19")
(source
(origin
(method url-fetch)
(uri (string-append "https://github.com/stcorp/coda/releases/download/"
version "/coda-" version ".tar.gz"))
(sha256
- (base32 "1zlzgcvwmmjm8mw8w4rg2rqy0pjilz7kyyxm0y4p8cbljbbjxxz0"))
+ (base32 "1fbxd2afm7dshd92p10yy8dwbr9gc1h1fmnnnmr7d0c5lnw80245"))
(patches (search-patches "coda-use-system-libs.patch"))
(modules '((guix build utils)))
(snippet
@@ -353,17 +353,17 @@ numbers.")
(define-public ocaml-gsl
(package
(name "ocaml-gsl")
- (version "1.19.3")
+ (version "1.22.0")
(source
(origin
(method url-fetch)
(uri
(string-append
- "https://github.com/mmottl/gsl-ocaml/releases/download/v"
- version"/gsl-ocaml-" version ".tar.gz"))
+ "https://github.com/mmottl/gsl-ocaml/releases/download/"
+ version "/gsl-" version ".tbz"))
(sha256
(base32
- "0nzp43hp8pbjqkrxnwp5lgjrabxayf61h18fjaydi0s5faq6f3xh"))))
+ "17vcswipliq1b2idbzx1z95kskn1a4q4s5v04igilg0f7lnkaarb"))))
(build-system ocaml-build-system)
(inputs
`(("gsl" ,gsl)))
@@ -2767,16 +2767,16 @@ full text searching.")
(define-public armadillo
(package
(name "armadillo")
- (version "7.800.2")
+ (version "9.100.4")
(source (origin
(method url-fetch)
(uri (string-append "mirror://sourceforge/arma/armadillo-"
version ".tar.xz"))
(sha256
(base32
- "1qqzy7dp891j9v7062mv1599hdwr97vqzrd3j2fl8c3gmc00dmzg"))))
+ "1pzvarfj4mf6xmhs6r8dxlgq6h994ajr8hsp09r4w0dw99za2r08"))))
(build-system cmake-build-system)
- (arguments `(#:tests? #f)) ;no test target
+ (arguments `(#:tests? #f)) ; no test target
(inputs
`(("openblas" ,openblas)
("lapack" ,lapack)