summaryrefslogtreecommitdiff
path: root/gnu/packages/maths.scm
diff options
context:
space:
mode:
authorPaul A. Patience <paul@apatience.com>2022-04-28 18:19:22 +0000
committerLudovic Courtès <ludo@gnu.org>2022-05-03 18:02:27 +0200
commite648957b7b99d140959311df6be46ed63338dd7f (patch)
tree4dc73cf2a8c049a855e414f3a384ebb1d949209b /gnu/packages/maths.scm
parentd1a6a795b3e29319c079cd0ab2ac8f68523e7fd1 (diff)
gnu: sundials: Add 5.8.0.
* gnu/packages/maths.scm (sundials-5, sundials-openmpi-5): New variables. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/maths.scm')
-rw-r--r--gnu/packages/maths.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index dd6334d4bd..0a92533d42 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -6198,6 +6198,29 @@ easily be incorporated into existing simulation codes.")
,%openmpi-setup)))))
(synopsis "SUNDIALS with MPI support")))
+(define-public sundials-5
+ (package
+ (inherit sundials)
+ (name "sundials")
+ (version "5.8.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/LLNL/sundials/releases/download/v"
+ version "/sundials-" version ".tar.gz"))
+ (sha256
+ (base32
+ "04x2x0jchf9kbcw2a1c6f4h4as8sr6k2snfz8z9k897pa4rl1vfl"))))))
+
+(define-public sundials-openmpi-5
+ (package/inherit sundials-5
+ (name "sundials-openmpi")
+ (propagated-inputs
+ (package-propagated-inputs sundials-openmpi))
+ (arguments
+ (package-arguments sundials-openmpi))
+ (synopsis (package-synopsis sundials-openmpi))))
+
(define-public sundials-julia
(package
(inherit sundials)