summaryrefslogtreecommitdiff
path: root/gnu/packages/messaging.scm
diff options
context:
space:
mode:
authorRyan Desfosses <rdes@protonmail.com>2021-09-12 16:24:01 -0400
committerLudovic Courtès <ludo@gnu.org>2021-12-04 23:03:54 +0100
commit20d525a842ca5d22edc4e2aa4a5d8225c2f5306c (patch)
tree323d7d1de0102739d6b27b58fd128e1e2cc5f8ec /gnu/packages/messaging.scm
parentac872546fc6a7f26870a6ab8407904c66adb0751 (diff)
gnu: Add libphonenumber
* gnu/package/messaging.scm (libphonenumber): New variable Co-authored-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/messaging.scm')
-rw-r--r--gnu/packages/messaging.scm35
1 files changed, 35 insertions, 0 deletions
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index 18c71b6ab3..2e3afb510e 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -2777,6 +2777,41 @@ asynchronicity.")
(home-page "https://github.com/gkdr/lurch")
(license license:gpl3+)))
+(define-public libphonenumber
+ (package
+ (name "libphonenumber")
+ (version "8.11.3")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/google/libphonenumber")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "06y3mh1d1mks6d0ynxp3980g712nkf8l5nyljpybsk326b246hg9"))))
+ (arguments
+ `(#:test-target "tests"
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'change-directory
+ (lambda _ (chdir "cpp"))))))
+ (build-system cmake-build-system)
+ (native-inputs
+ `(("googletest" ,googletest)
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("boost" ,boost)
+ ("protobuf" ,protobuf)
+ ("icu4c" ,icu4c)))
+ (synopsis "Library for parsing and using phone numbers")
+ (description
+ "This package provides a C++ library for parsing, formatting, and
+validating international phone numbers.")
+ (home-page "https://github.com/google/libphonenumber")
+ (license license:asl2.0)))
+
+
(define-public chatty
(package
(name "chatty")