summaryrefslogtreecommitdiff
path: root/gnu/packages/messaging.scm
diff options
context:
space:
mode:
authorWilko Meyer <w@wmeyer.eu>2024-04-28 21:11:30 +0200
committerLudovic Courtès <ludo@gnu.org>2024-05-31 13:55:43 +0200
commit734eaf5ce0ec7ea0a45ec348a2fdf945e5b63fa9 (patch)
treeb74218799facc63affd6a2c5471462d611ed9cfc /gnu/packages/messaging.scm
parentaccd977ab16ecdc88c5ac0e96cf02a382cb77a7e (diff)
gnu: Add biboumi.
* gnu/packages/messaging.scm (biboumi): New variable. * gnu/packages/patches/biboumi-cmake-ignore-git.patch: New patch. * gnu/local.mk (dist_patch_DATA): Add it. Change-Id: Ibb2bcadc8f64cbda3a0dbfe8ef5a931c52052658 Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/messaging.scm')
-rw-r--r--gnu/packages/messaging.scm44
1 files changed, 44 insertions, 0 deletions
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index 022f216934..e14536b957 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -41,6 +41,7 @@
;;; Copyright © 2023 Yovan Naumovski <yovan@gorski.stream>
;;; Copyright © 2023 gemmaro <gemmaro.dev@gmail.com>
;;; Copyright © 2024 Carlo Zancanaro <carlo@zancanaro.id.au>
+;;; Copyright © 2024 Wilko Meyer <w@wmeyer.eu>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -163,6 +164,49 @@
#:use-module (guix packages)
#:use-module (guix utils))
+(define-public biboumi
+ (package
+ (name "biboumi")
+ (version "9.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://git.louiz.org/biboumi/snapshot/biboumi-"
+ version ".tar.xz"))
+ (sha256
+ (base32 "1jvygri165aknmvlinx3jb8cclny6cxdykjf8dp0a3l3228rmzqy"))
+ ;; see https://sources.debian.org/patches/biboumi/9.0-5/2001_cmake_ignore_git.patch/
+ (patches (search-patches "biboumi-cmake-ignore-git.patch"))))
+ (arguments
+ ;; Tests seem to partially depend on networking as well as
+ ;; louiz/Catch which we remove as a dependency via the patch above as
+ ;; the repository seems dead. Deactivating those for now, possibly fix
+ ;; some of them later.
+ `(#:tests? #f
+ #:configure-flags '("-DWITHOUT_SYSTEMD=1")
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'fix-cmake-substitutions
+ (lambda* (#:key outputs #:allow-other-keys)
+ (substitute* "CMakeLists.txt"
+ (("/etc") (string-append (assoc-ref outputs "out") "/etc"))))))))
+ (build-system cmake-build-system)
+ (inputs (list botan
+ expat
+ libiconv
+ libidn
+ openssl
+ postgresql ;; libpq
+ sqlite
+ ;; TODO: package optional dependency: udns
+ (list util-linux "lib") ;; libuuid
+ pkg-config))
+ (home-page "https://biboumi.louiz.org")
+ (synopsis "Biboumi is a XMPP gateway that connects to IRC")
+ (description "Biboumi is a Free, Libre and Open Source XMPP gateway that connects to IRC
+servers and translates between the two protocols. Its goal is to let XMPP
+users take part in IRC discussions, using their favourite XMPP client.")
+ (license license:zlib)))
+
(define-public omemo-wget
(package
(name "omemo-wget")