summaryrefslogtreecommitdiff
path: root/gnu/packages/messaging.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2021-11-03 02:44:21 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2021-11-03 11:19:54 +0100
commit914bcc6f985f631f69a5d85a77a682bbb8500a35 (patch)
treedc25453947f78cf0c0253e8ab832920f71bd4f56 /gnu/packages/messaging.scm
parent7c62015837e6f8a0e831e2c9da51d9664e95115c (diff)
gnu: prosody: Update to 0.11.10.
* gnu/packages/messaging.scm (prosody): Update to 0.11.10. [arguments]: Don't explicitly return #t from phases.
Diffstat (limited to 'gnu/packages/messaging.scm')
-rw-r--r--gnu/packages/messaging.scm13
1 files changed, 5 insertions, 8 deletions
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index d07c1c6566..41edecd75c 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -1331,14 +1331,14 @@ default.")
(define-public prosody
(package
(name "prosody")
- (version "0.11.9")
+ (version "0.11.10")
(source (origin
(method url-fetch)
(uri (string-append "https://prosody.im/downloads/source/"
"prosody-" version ".tar.gz"))
(sha256
(base32
- "02gzvsaq0l5lx608sfh7hfz14s6yfsr4sr4kzcsqd1cxljp35h6c"))))
+ "1q84s9cq7cgzd295qxa2iy0r3vd3v3chbck62bdx3pd6skk19my6"))))
(build-system gnu-build-system)
(arguments
`(#:tests? #f ;tests require "busted"
@@ -1354,16 +1354,14 @@ default.")
;; The configure script aborts when it encounters unexpected
;; arguments. Make it more tolerant.
(substitute* "configure"
- (("exit 1") ""))
- #t))
+ (("exit 1") ""))))
(add-after 'unpack 'fix-makefile
(lambda _
(substitute* "GNUmakefile"
;; prosodyctl needs to read the configuration file.
(("^INSTALLEDCONFIG =.*") "INSTALLEDCONFIG = /etc/prosody\n")
;; prosodyctl needs a place to put auto-generated certificates.
- (("^INSTALLEDDATA =.*") "INSTALLEDDATA = /var/lib/prosody\n"))
- #t))
+ (("^INSTALLEDDATA =.*") "INSTALLEDDATA = /var/lib/prosody\n"))))
(add-after 'install 'wrap-programs
(lambda* (#:key inputs outputs #:allow-other-keys)
;; Make sure all executables in "bin" find the required Lua
@@ -1399,8 +1397,7 @@ default.")
`("LUA_PATH" ";" = (,lua-path))
`("LUA_CPATH" ";" = (,lua-cpath))
`("PATH" ":" prefix ,path)))
- (find-files bin ".*"))
- #t))))))
+ (find-files bin ".*"))))))))
(inputs
`(("libidn" ,libidn)
("openssl" ,openssl)