summaryrefslogtreecommitdiff
path: root/gnu/packages/messaging.scm
diff options
context:
space:
mode:
authorRaghav Gururajan <rg@raghavgururajan.name>2021-06-16 20:20:55 -0400
committerRaghav Gururajan <rg@raghavgururajan.name>2021-06-22 01:02:01 -0400
commitadf485c815fc8edf67e21fe349da838eae345e32 (patch)
tree69caa34e5dd92474f9373fc8db224a185a4c7a42 /gnu/packages/messaging.scm
parent43cec0d117b4969ba2fc63c79a241c5e06c78f3d (diff)
gnu: dino: Enable some features.
* gnu/packages/messaging.scm (dino): Add comments for v0.3.0 release. [inputs]: Add gspell and icu4c.
Diffstat (limited to 'gnu/packages/messaging.scm')
-rw-r--r--gnu/packages/messaging.scm17
1 files changed, 17 insertions, 0 deletions
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index 1a6a065e0f..22e1c370aa 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -1242,6 +1242,14 @@ Encryption to Gajim.")
(guix build glib-or-gtk-build-system))
#:phases
(modify-phases %standard-phases
+ ;; To be enabled in v0.3.0, for A/V support.
+ ;;(add-after 'install 'wrap
+ ;;(lambda* (#:key outputs #:allow-other-keys)
+ ;;(let* ((out (assoc-ref outputs "out"))
+ ;;(dino (string-append out "/bin/dino"))
+ ;;(gst-plugin-path (getenv "GST_PLUGIN_SYSTEM_PATH")))
+ ;;(wrap-program dino
+ ;;`("GST_PLUGIN_SYSTEM_PATH" ":" prefix (,gst-plugin-path))))))
(add-after 'install 'glib-or-gtk-wrap
(assoc-ref glib-or-gtk:%standard-phases 'glib-or-gtk-wrap)))))
(native-inputs
@@ -1252,6 +1260,7 @@ Encryption to Gajim.")
("pkg-config" ,pkg-config)
("vala" ,vala)))
(inputs
+ ;; NOTE: Commented-out lines are to be enabled in v0.3.0.
`(("atk" ,atk)
("cairo" ,cairo)
("gdk-pixbuf" ,gdk-pixbuf+svg)
@@ -1259,15 +1268,23 @@ Encryption to Gajim.")
("glib-networking" ,glib-networking)
("gpgme" ,gpgme)
("gsettings-desktop-schemas" ,gsettings-desktop-schemas)
+ ("gspell" ,gspell) ;for spell-check support
+ ;;("gstreamer" ,gstreamer) ;for A/V support
+ ;;("gst-plugins-base" ,gst-plugins-base)
+ ;;("gst-plugins-good" ,gst-plugins-good)
("gtk+" ,gtk+)
+ ("icu4c" ,icu4c) ;for emoji support
+ ;;("libcanberra" ,libcanberra) ;for sound-notification support
("libgcrypt" ,libgcrypt)
("libgee" ,libgee)
("libnice" ,libnice)
("libsignal-protocol-c" ,libsignal-protocol-c)
("libsoup" ,libsoup)
+ ;;("libsrtp" ,libsrtp) ;for calls support
("pango" ,pango)
("qrencode" ,qrencode)
("sqlite" ,sqlite)))
+ ;;("webrtc-audio-processing" ,webrtc-audio-processing))) ;for A/V support
(synopsis "Graphical Jabber/XMPP Client using GTK+/Vala")
(description "Dino is a chat client for the desktop. It focuses on providing
a minimal yet reliable Jabber/XMPP experience and having encryption enabled by