summaryrefslogtreecommitdiff
path: root/gnu/packages/music.scm
diff options
context:
space:
mode:
authorSughosha <Sughosha@proton.me>2022-12-30 20:28:27 +0000
committerLudovic Courtès <ludo@gnu.org>2023-01-19 17:54:50 +0100
commit3846ceec4e5016394f8f9ae122e7c092ab0c0bf3 (patch)
tree80293648bc929d1e98db5af4144a6f478d573477 /gnu/packages/music.scm
parentf59df2f488061c68bb828470aef5c14811df4c4a (diff)
gnu: Add petri-foo.
* gnu/packages/music.scm (petri-foo): New public variable. * gnu/packages/patches/petri-foo-0.1.87-fix-recent-file-not-exist.patch * gnu/local.mk (GNU_SYSTEM_MODULES): Add the new patch file. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/music.scm')
-rw-r--r--gnu/packages/music.scm41
1 files changed, 41 insertions, 0 deletions
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index aeb86a4799..65bb6d29f7 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -2178,6 +2178,47 @@ Editor. It is compatible with Power Tab Editor 1.7 and Guitar Pro.")
users to select LV2 plugins and run them with jalv.")
(license license:public-domain)))
+(define-public petri-foo
+ (package
+ (name "petri-foo")
+ (version "0.1.87")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://sourceforge/petri-foo/Source"
+ "/petri-foo-" version ".tar.bz2"))
+ (sha256
+ (base32
+ "0b25iicgn8c42487fdw32ycfrll1pm2zjgy5djvgw6mfcaa4gizh"))
+ (modules '((guix build utils)))
+ ;; https://github.com/petri-foo/Petri-Foo/pull/43
+ (snippet '(begin
+ (substitute* "gui/gui.c"
+ (("#include \\\"waveform\\.h\\\"")
+ (string-append
+ "#include \"waveform.h\""
+ "\n\nGtkRecentManager *recent_manager;")))
+ (substitute* "gui/gui.h"
+ (("GtkRecentManager \\*recent_manager;")
+ "extern GtkRecentManager *recent_manager;"))))))
+ (build-system cmake-build-system)
+ (arguments (list #:tests? #f)) ;no test target
+ (native-inputs (list pkg-config))
+ (inputs (list alsa-lib
+ glib
+ jack-1
+ libgnomecanvas
+ liblo
+ libsamplerate
+ libsndfile
+ libxml2
+ openssl))
+ (home-page "https://petri-foo.sourceforge.net/")
+ (synopsis "Audio sampler for JACK")
+ (description
+ "Petri-Foo is a fork of the Specimen sampler project intended to run under
+a JACK session.")
+ (license license:gpl2)))
+
(define-public mixxx
(package
(name "mixxx")