summaryrefslogtreecommitdiff
path: root/gnu/packages/music.scm
diff options
context:
space:
mode:
authorAlexandros Theodotou <alex@zrythm.org>2020-05-27 01:44:02 +0100
committerMarius Bakke <marius@gnu.org>2020-05-30 16:41:38 +0200
commitce1cd4340455b7599385dba2248888a72d3e4d4f (patch)
treec6426a35329ad01629697c9f9eabdff03be2d966 /gnu/packages/music.scm
parent968612b76a157a5270f7b959a09d6e2268f04c4c (diff)
gnu: Add spectacle-analyzer.
* gnu/packages/music.scm (spectacle-analyzer): new variable. Signed-off-by: Marius Bakke <marius@gnu.org>
Diffstat (limited to 'gnu/packages/music.scm')
-rw-r--r--gnu/packages/music.scm44
1 files changed, 44 insertions, 0 deletions
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 09827c7c93..ac149a804c 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -141,6 +141,7 @@
#:use-module (gnu packages tls)
#:use-module (gnu packages version-control)
#:use-module (gnu packages video)
+ #:use-module (gnu packages vim) ;for 'xxd'
#:use-module (gnu packages web)
#:use-module (gnu packages wxwidgets)
#:use-module (gnu packages xml)
@@ -4940,6 +4941,49 @@ and debugging of event signal flows inside plugin graphs.")
(home-page "https://open-music-kontrollers.ch/lv2/sherlock/")
(license license:artistic2.0)))
+(define-public spectacle-analyzer
+ (package
+ (name "spectacle-analyzer")
+ (version "1.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/jpcima/spectacle.git")
+ (commit (string-append "v" version))
+ ;; Bundles a specific commit of the DISTRHO plugin framework.
+ (recursive? #t)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0xiqa6z8g68lcvnwhws4j7c4py35r9d20cirrili7ycyp3a6149a"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f ; no check target
+ #:make-flags
+ (list "CC=gcc"
+ (string-append "PREFIX=" (assoc-ref %outputs "out")))
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure))))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)
+ ("xxd" ,xxd)))
+ (inputs
+ `(("cairo", cairo)
+ ("fftw", fftw)
+ ("fftwf", fftwf)
+ ("jack", jack-1)
+ ("lv2", lv2)
+ ("mesa", mesa)))
+ (synopsis "Realtime graphical spectrum analyzer")
+ (description "Spectacle is a real-time spectral analyzer using the
+short-time Fourier transform, available as LV2 audio plugin and JACK client.")
+ (home-page "https://github.com/jpcima/spectacle")
+ ;; The project is licensed under the ISC license, and files in
+ ;; sources/plugin carry the Expat license.
+ (license (list license:isc license:expat))))
+
(define-public x42-plugins
(package
(name "x42-plugins")