summaryrefslogtreecommitdiff
path: root/gnu/packages/music.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-08-31 18:02:57 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2020-08-31 18:03:11 +0200
commitf46379c18a5c7529db20bebb1bf4782de90bab91 (patch)
tree0c73da3f8cc73cb5d2a549777ad2f3dcb78405f6 /gnu/packages/music.scm
parent312789abc565aa7f86d7d6554c190ec34a77a26c (diff)
gnu: yoshimi: Update to 1.7.2.
* gnu/packages/music.scm (yoshimi): Update to 1.7.2. [source]: Use URL-FETCH once more.
Diffstat (limited to 'gnu/packages/music.scm')
-rw-r--r--gnu/packages/music.scm109
1 files changed, 52 insertions, 57 deletions
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index cdfe7aff7d..106b171fca 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -2304,66 +2304,61 @@ capabilities, custom envelopes, effects, etc.")
(license license:gpl2)))
(define-public yoshimi
- ;; Release 1.7.1 doesn't build with our version of LV2. Applying only
- ;; 86996cbb235f0fe138ae814a6758c2c8ba1c2a38 is not enough.
- (let ((commit "bfcadc6537dbcb301cd93346f21d36bcbffa36c7")
- (revision "0"))
- (package
- (name "yoshimi")
- (version (git-version "1.7.1" revision commit))
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://git.code.sf.net/p/yoshimi/code")
- (commit commit)))
- (sha256
- (base32 "0vhdxj7ky4iyq11r5wj9jwavjih4xvcn2djbrlmwpkdhrzpy6myl"))
- (file-name (git-file-name name version))))
- (build-system cmake-build-system)
- (arguments
- `(#:tests? #f ; there are no tests
- #:configure-flags
- (list (string-append "-DCMAKE_INSTALL_DATAROOTDIR="
- (assoc-ref %outputs "out") "/share"))
- #:phases
- (modify-phases %standard-phases
- (add-before 'configure 'enter-dir
- (lambda _ (chdir "src") #t))
- ;; Move SSE compiler optimization flags from generic target to
- ;; athlon64 and core2 targets, because otherwise the build would fail
- ;; on non-Intel machines.
- (add-after 'unpack 'remove-sse-flags-from-generic-target
- (lambda _
- (substitute* "src/CMakeLists.txt"
- (("-msse -msse2 -mfpmath=sse") "")
- (("-march=(athlon64|core2)" flag)
- (string-append flag " -msse -msse2 -mfpmath=sse")))
- #t)))))
- (inputs
- `(("boost" ,boost)
- ("fftwf" ,fftwf)
- ("alsa-lib" ,alsa-lib)
- ("jack" ,jack-1)
- ("fontconfig" ,fontconfig)
- ("minixml" ,minixml)
- ("mesa" ,mesa)
- ("fltk" ,fltk)
- ("lv2" ,lv2)
- ("readline" ,readline)
- ("ncurses" ,ncurses)
- ("cairo" ,cairo)
- ("zlib" ,zlib)))
- (native-inputs
- `(("pkg-config" ,pkg-config)))
- (home-page "http://yoshimi.sourceforge.net/")
- (synopsis "Multi-paradigm software synthesizer")
- (description
- "Yoshimi is a fork of ZynAddSubFX, a feature-heavy real-time software
+ (package
+ (name "yoshimi")
+ (version "1.7.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://sourceforge/yoshimi/"
+ (version-major+minor version)
+ "/yoshimi-" version ".tar.bz2"))
+ (sha256
+ (base32 "1vxrksg199pcgiykq0nsf67ihfk2ny2jmpf6gzdb3nk9iphm7di3"))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:tests? #f ; there are no tests
+ #:configure-flags
+ (list (string-append "-DCMAKE_INSTALL_DATAROOTDIR="
+ (assoc-ref %outputs "out") "/share"))
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'configure 'enter-dir
+ (lambda _ (chdir "src") #t))
+ ;; Move SSE compiler optimization flags from generic target to
+ ;; athlon64 and core2 targets, because otherwise the build would fail
+ ;; on non-Intel machines.
+ (add-after 'unpack 'remove-sse-flags-from-generic-target
+ (lambda _
+ (substitute* "src/CMakeLists.txt"
+ (("-msse -msse2 -mfpmath=sse") "")
+ (("-march=(athlon64|core2)" flag)
+ (string-append flag " -msse -msse2 -mfpmath=sse")))
+ #t)))))
+ (inputs
+ `(("boost" ,boost)
+ ("fftwf" ,fftwf)
+ ("alsa-lib" ,alsa-lib)
+ ("jack" ,jack-1)
+ ("fontconfig" ,fontconfig)
+ ("minixml" ,minixml)
+ ("mesa" ,mesa)
+ ("fltk" ,fltk)
+ ("lv2" ,lv2)
+ ("readline" ,readline)
+ ("ncurses" ,ncurses)
+ ("cairo" ,cairo)
+ ("zlib" ,zlib)))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (home-page "http://yoshimi.sourceforge.net/")
+ (synopsis "Multi-paradigm software synthesizer")
+ (description
+ "Yoshimi is a fork of ZynAddSubFX, a feature-heavy real-time software
synthesizer. It offers three synthesizer engines, multitimbral and polyphonic
synths, microtonal capabilities, custom envelopes, effects, etc. Yoshimi
improves on support for JACK features, such as JACK MIDI.")
- (license license:gpl2))))
+ (license license:gpl2)))
(define-public libgig
(package