summaryrefslogtreecommitdiff
path: root/gnu/packages/networking.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-03-22 09:41:31 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-03-22 10:09:04 -0400
commit4f8a13b9fbfd0efcb94ee8da46b09c6dbe84ac4b (patch)
tree50a5a84457bf54170b818662cb15800b6c820eb3 /gnu/packages/networking.scm
parent19af6d94340ce3b5655dab30eaa295661dbe4e89 (diff)
gnu: wireshark: Update dependencies, use Qt 6.
* gnu/packages/networking.scm (wireshark) [arguments] <#:configure-flags>: Add -DUSE_qt6=ON. [inputs]: Replace lua-5.2 with lua, qtbase-5 with qtbase, qtmultimedia-5 with qtmultimedia, qtsvg-5 with qtsvg. Add qt5compat. [native-inputs]: replace qttools-5 with qttools.
Diffstat (limited to 'gnu/packages/networking.scm')
-rw-r--r--gnu/packages/networking.scm14
1 files changed, 8 insertions, 6 deletions
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index 26451c91a9..ecb1d16615 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -1773,7 +1773,8 @@ of the same name.")
;; libraries, which would otherwise cause the validate-runpath phase to
;; fail.
#:configure-flags #~(list (string-append "-DCMAKE_MODULE_LINKER_FLAGS="
- "-Wl,-rpath=" #$output "/lib"))
+ "-Wl,-rpath=" #$output "/lib")
+ "-DUSE_qt6=ON")
#:phases
#~(modify-phases %standard-phases
(replace 'check
@@ -1799,14 +1800,15 @@ of the same name.")
libssh
libxml2
lz4
- lua-5.2 ;Lua 5.3 unsupported
+ lua
mit-krb5
`(,nghttp2 "lib")
minizip
pcre2
- qtbase-5
- qtmultimedia-5
- qtsvg-5
+ qt5compat
+ qtbase
+ qtmultimedia
+ qtsvg
sbc
snappy
zlib
@@ -1819,7 +1821,7 @@ of the same name.")
perl
pkg-config
python-wrapper
- qttools-5))
+ qttools))
(synopsis "Network traffic analyzer")
(description "Wireshark is a network protocol analyzer, or @dfn{packet
sniffer}, that lets you capture and interactively browse the contents of