summaryrefslogtreecommitdiff
path: root/gnu/packages/networking.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-08-31 19:28:33 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2020-08-31 20:32:50 +0200
commit55d6b357a937166ba19beb036b87519293e3bc2d (patch)
treea6c166a2081ce365ac2a00790699895910a861b2 /gnu/packages/networking.scm
parent5237aa444da9c6063a5b2a0865b22c1255d72864 (diff)
gnu: rtmpdump: Don't install the static library.
* gnu/packages/networking.scm (rtmpdump)[arguments]: Add an ‘omit-static-library’ phase.
Diffstat (limited to 'gnu/packages/networking.scm')
-rw-r--r--gnu/packages/networking.scm8
1 files changed, 8 insertions, 0 deletions
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index e80c192a50..1340bef8f0 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -280,6 +280,14 @@ GLib-based library, libnice, as well as GStreamer elements to use it.")
(string-append "prefix=" (assoc-ref %outputs "out")))
#:phases
(modify-phases %standard-phases
+ (add-after 'unpack 'omit-static-library
+ (lambda _
+ (substitute* "librtmp/Makefile"
+ (("cp librtmp\\.a .*") ; don't install it
+ "")
+ (("librtmp\\.a ") ; don't build it
+ ""))
+ #t))
(delete 'configure))))
(inputs
`(("openssl" ,openssl-1.0)