summaryrefslogtreecommitdiff
path: root/gnu/packages/networking.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2021-05-27 17:05:05 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2021-05-27 18:20:35 +0200
commitf2c66d70fca921c59328cd739eaa039f5edfa4f4 (patch)
treec2189ccc9737a6044358664d1d885fe095735bb2 /gnu/packages/networking.scm
parenta16ce0b11d32e6344e4a2e148b1bf6ed34b189b3 (diff)
gnu: iperf: Update to 3.10.
* gnu/packages/networking.scm (iperf): Update to 3.10. [source]: Build from git.
Diffstat (limited to 'gnu/packages/networking.scm')
-rw-r--r--gnu/packages/networking.scm18
1 files changed, 10 insertions, 8 deletions
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index 8bcaa98fbb..6cb1cc9f7f 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -2347,14 +2347,16 @@ that block port 22.")
(define-public iperf
(package
(name "iperf")
- (version "3.9")
- (source (origin
- (method url-fetch)
- (uri (string-append "http://downloads.es.net/pub/iperf"
- "/iperf-" version ".tar.gz"))
- (sha256
- (base32
- "0f601avdmzpwsa3lbi0ppjhkrdipm5wifhhxy5czf99370k3mdi4"))))
+ (version "3.10")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/esnet/iperf")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "102wcyl4j7c7lj7z87b5xlhj1ark88v4f3q9pmmljw8ksn2w1m2g"))))
(build-system gnu-build-system)
(synopsis "TCP, UDP and SCTP bandwidth measurement tool")
(description