summaryrefslogtreecommitdiff
path: root/gnu/packages/ocaml.scm
diff options
context:
space:
mode:
authorpukkamustard <pukkamustard@posteo.net>2022-12-16 13:25:25 +0000
committerJulien Lepiller <julien@lepiller.eu>2022-12-21 22:10:38 +0100
commit134480a381cbf38453c8cd4333b873ad2a51765e (patch)
treeed6f5ae83de153430e23cab218fceadd2545fffc /gnu/packages/ocaml.scm
parentf127f0fbf3112e7c3ebeeeb0da8b7747ca3b0f20 (diff)
gnu: Add ocaml5.0-merlin-lib.
* gnu/packages/ocaml.scm (ocaml5.0-merlin-lib): New variable. Signed-off-by: Julien Lepiller <julien@lepiller.eu>
Diffstat (limited to 'gnu/packages/ocaml.scm')
-rw-r--r--gnu/packages/ocaml.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index c31ad6c8f9..30e895eee6 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -5384,12 +5384,34 @@ serializers and deserializers from type definitions.")
(arguments '(#:package "merlin-lib"
#:tests? #f)) ; no tests
(propagated-inputs (list ocaml-csexp ocaml-menhir))
+ (properties `((ocaml5.0-variant . ,(delay ocaml5.0-merlin-lib))))
(home-page "https://ocaml.github.io/merlin/")
(synopsis "Merlin libraries")
(description "These libraries provides access to low-level compiler
interfaces and the standard higher-level merlin protocol.")
(license license:expat)))
+;; the 500 indicates that this version is for OCaml 5.0
+(define ocaml-merlin-lib-500
+ (package
+ (inherit ocaml-merlin-lib)
+ (name "ocaml-merlin-lib")
+ (version "4.7.1-500")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/ocaml/merlin")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "05a87i2dkzv800nwb6y7b2j45avg8gs3gzb5a98wrj1i5zjqwh01"))))
+ (properties '())))
+
+(define-public ocaml5.0-merlin-lib
+ (package-with-ocaml5.0 ocaml-merlin-lib-500))
+
(define-public ocaml-dot-merlin-reader
(package
(inherit ocaml-merlin-lib)