summaryrefslogtreecommitdiff
path: root/gnu/packages/ocaml.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-08-31 20:00:19 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2020-08-31 20:32:50 +0200
commit2d3370c4ec22cea965cd934dd30909cd5929a85a (patch)
treef803367e7e8a997e8ca8123cffac89dc8b0628dc /gnu/packages/ocaml.scm
parent4a7243fcfb1aa6f967a16cb31510aa421012fd56 (diff)
gnu: ocamlify: Update to 0.0.2.
* gnu/packages/ocaml.scm (ocamlify): Update to 0.0.2. [arguments]: Add a ‘disable-safe-string’ phase.
Diffstat (limited to 'gnu/packages/ocaml.scm')
-rw-r--r--gnu/packages/ocaml.scm10
1 files changed, 8 insertions, 2 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index df1ca764aa..33c3fa0494 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -2258,18 +2258,24 @@ radix-64 representation. It is specified in RFC 4648.")
(define-public ocamlify
(package
(name "ocamlify")
- (version "0.0.1")
+ (version "0.0.2")
(source
(origin
(method url-fetch)
(uri (string-append "https://download.ocamlcore.org/ocamlify/ocamlify/"
version "/ocamlify-" version ".tar.gz"))
(sha256
- (base32 "1j9nb3vjqbdsx3d6jazixgrh776051zkrc06nsc5q5ilp1jhrwkm"))))
+ (base32 "1f0fghvlbfryf5h3j4as7vcqrgfjb4c8abl5y0y5h069vs4kp5ii"))))
(build-system ocaml-build-system)
(arguments
`(#:phases
(modify-phases %standard-phases
+ (add-after 'unpack 'disable-safe-string
+ ;; Work around ‘Error: This expression has type string but an
+ ;; expression was expected of type bytes’ since OCaml 4.06.
+ (lambda _
+ (setenv "OCAMLPARAM" "safe-string=0,_")
+ #t))
(delete 'check) ; tests are run during the build
(replace 'configure
(lambda* (#:key outputs #:allow-other-keys)