summaryrefslogtreecommitdiff
path: root/gnu/packages/ocaml.scm
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2021-11-20 12:45:36 +0100
committerJulien Lepiller <julien@lepiller.eu>2021-11-20 17:06:30 +0100
commit426faa76d1646fdc35d1f28d6319963d3f881324 (patch)
treea66bcb8eff6bd728cc531796cfacff8434c84ddb /gnu/packages/ocaml.scm
parentc618f4a9cc4dd8aea32cea0b444322a5500a5c24 (diff)
gnu: ocaml-fmt: Update to 0.9.0.
* gnu/packages/ocaml.scm (ocaml-fmt): Update to 0.9.0. (ocaml4.07-fmt): New variable.
Diffstat (limited to 'gnu/packages/ocaml.scm')
-rw-r--r--gnu/packages/ocaml.scm19
1 files changed, 17 insertions, 2 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index a15842a8b6..537e8bcfed 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -2222,14 +2222,14 @@ most of the POSIX and GNU conventions.")
(define-public ocaml-fmt
(package
(name "ocaml-fmt")
- (version "0.8.9")
+ (version "0.9.0")
(source
(origin
(method url-fetch)
(uri (string-append "http://erratique.ch/software/fmt/releases/fmt-"
version ".tbz"))
(sha256 (base32
- "0gkkkj4x678vxdda4xaw2dd44qjacavsvn5nx8gydfwah6pjbkxk"))))
+ "0q8j2in2473xh7k4hfgnppv9qy77f2ih89yp6yhpbp92ba021yzi"))))
(build-system ocaml-build-system)
(native-inputs
`(("ocamlbuild" ,ocamlbuild)
@@ -2245,12 +2245,27 @@ most of the POSIX and GNU conventions.")
#:phases
(modify-phases %standard-phases
(delete 'configure))))
+ (properties `((ocaml4.07-variant . ,(delay ocaml4.07-fmt))))
(home-page "https://erratique.ch/software/fmt")
(synopsis "OCaml Format pretty-printer combinators")
(description "Fmt exposes combinators to devise Format pretty-printing
functions.")
(license license:isc)))
+(define-public ocaml4.07-fmt
+ (package-with-ocaml4.07
+ (package
+ (inherit ocaml-fmt)
+ (version "0.8.9")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://erratique.ch/software/fmt/releases/fmt-"
+ version ".tbz"))
+ (sha256
+ (base32
+ "0gkkkj4x678vxdda4xaw2dd44qjacavsvn5nx8gydfwah6pjbkxk"))))
+ (properties '()))))
+
(define-public ocaml-astring
(package
(name "ocaml-astring")