summaryrefslogtreecommitdiff
path: root/gnu/packages/ocaml.scm
diff options
context:
space:
mode:
authorraingloom <raingloom@riseup.net>2023-02-15 23:00:13 +0100
committerChristopher Baines <mail@cbaines.net>2023-02-17 15:44:56 +0000
commit5f0d2ed20b31d58a53e907ff54342d0c72ef4198 (patch)
tree145797fad9913057bd753c4afb9f45d80f1a646b /gnu/packages/ocaml.scm
parent3831cdad63d8b93f7b1e904811e0adce6d55bd63 (diff)
gnu: Add ocaml-core-unix.
* gnu/packages/ocaml.scm (ocaml-core-unix): New variable. Signed-off-by: Christopher Baines <mail@cbaines.net>
Diffstat (limited to 'gnu/packages/ocaml.scm')
-rw-r--r--gnu/packages/ocaml.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index d4240162e8..521a98e583 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -8357,6 +8357,38 @@ the full Core is not available, such as in Javascript.")
;; MLton and sjs
license:expat)))))
+(define-public ocaml-core-unix
+ (package
+ (name "ocaml-core-unix")
+ (version "0.15.2")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/janestreet/core_unix")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0h6lqaxpp4r06a63k8yr0g9y7wc8r35v2xzqgvkiiq1ypa48zzgm"))))
+ (build-system dune-build-system)
+ (propagated-inputs (list ocaml-core
+ ocaml-core-kernel
+ ocaml-expect-test-helpers-core
+ ocaml-jane-street-headers
+ ocaml-jst-config
+ ocaml-intrinsics
+ ocaml-ppx-jane
+ ocaml-sexplib
+ ocaml-timezone
+ ocaml-spawn))
+ (properties `((upstream-name . "core_unix")))
+ (home-page "https://github.com/janestreet/core_unix")
+ (synopsis "Unix-specific portions of Core")
+ (description
+ "Unix-specific extensions to some of the modules defined in core and
+core_kernel.")
+ (license license:expat)))
+
(define-public ocaml-timezone
(package
(name "ocaml-timezone")