summaryrefslogtreecommitdiff
path: root/gnu/packages/ocaml.scm
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2021-11-19 13:55:19 +0100
committerJulien Lepiller <julien@lepiller.eu>2021-11-19 13:55:19 +0100
commit6460345725a5021c8740f77e68724e5bb880d6a4 (patch)
treee48c81892837d673c581813297f3445f589d3ad7 /gnu/packages/ocaml.scm
parentb5d51bb19e790baee9b16a3325397ec92d8e7625 (diff)
gnu: ocaml-ounit: Update to 2.2.4.
* gnu/packages/ocaml.scm (ocaml-ounit): Update to 2.2.4. Inherit from ocaml-ounit2. [arguments]: Use installation instructions from opam.
Diffstat (limited to 'gnu/packages/ocaml.scm')
-rw-r--r--gnu/packages/ocaml.scm19
1 files changed, 7 insertions, 12 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 8c83cbca9c..54c1188d90 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -1360,22 +1360,17 @@ to JUnit and other XUnit testing frameworks.")
;; note that some tests may hang for no obvious reason.
(define-public ocaml-ounit
(package
+ (inherit ocaml-ounit2)
(name "ocaml-ounit")
- (version "2.0.8")
- (source (origin
- (method url-fetch)
- (uri (ocaml-forge-uri "ounit" version 1749))
- (sha256
- (base32
- "03ifp9hjcxg4m5j190iy373jcn4039d3vy10kmd8p4lfciwzwc1f"))))
- (build-system ocaml-build-system)
- (native-inputs
- `(("libxml2" ,libxml2) ; for xmllint
- ("ocamlbuild" ,ocamlbuild)))
(arguments
`(#:phases
(modify-phases %standard-phases
- (delete 'check)))) ; tests are run during build
+ (replace 'install
+ (lambda _
+ (invoke "make" "install-ounit" ,(string-append "version="
+ (package-version ocaml-ounit2))))))))
+ (propagated-inputs
+ `(("ocaml-ounit2" ,ocaml-ounit2)))
(home-page "http://ounit.forge.ocamlcore.org")
(synopsis "Unit testing framework for OCaml")
(description "Unit testing framework for OCaml. It is similar to JUnit and