summaryrefslogtreecommitdiff
path: root/gnu/packages/ocaml.scm
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2021-10-23 15:22:11 +0200
committerEfraim Flashner <efraim@flashner.co.il>2021-11-16 15:43:51 +0200
commit8000fc4fa022c3053574b580639f67edd8321c31 (patch)
tree0f2ea7a01b12dd671ad8e912b2f84ad689d52746 /gnu/packages/ocaml.scm
parent9bbbac6783bcdace17d967e85c8ae8d14cbf1ef9 (diff)
gnu: Add ocaml4.07-re.
* gnu/packages/ocaml.scm (ocaml4.07-re): New variable. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu/packages/ocaml.scm')
-rw-r--r--gnu/packages/ocaml.scm14
1 files changed, 14 insertions, 0 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index b04ca1d287..932220d188 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -3353,6 +3353,7 @@ standard iterator type starting from 4.07.")
`(("ocaml-seq" ,ocaml-seq)))
(native-inputs
`(("ounit" ,ocaml-ounit)))
+ (properties `((ocaml4.07-variant . ,(delay ocaml4.07-re))))
(home-page "https://github.com/ocaml/ocaml-re/")
(synopsis "Regular expression library for OCaml")
(description "Pure OCaml regular expressions with:
@@ -3365,6 +3366,19 @@ standard iterator type starting from 4.07.")
@end enumerate")
(license license:expat)))
+(define-public ocaml4.07-re
+ (package-with-ocaml4.07
+ (package
+ (inherit ocaml-re)
+ (arguments
+ `(#:test-target "."
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'fix-dune-version
+ (lambda _
+ (delete-file "dune-project"))))))
+ (properties '()))))
+
(define-public ocaml-ocplib-endian
(package
(name "ocaml-ocplib-endian")